Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 4.2.7
    • None
    • 1

    Description

      Users have reported incompatibility with Consul 1.9.0. Let's see if we can fix that.

      Attachments

        1. new-agent-self-response.json
          15 kB
          David Nault
        2. old-agent-self-response.json
          11 kB
          David Nault

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            david.nault David Nault added a comment - - edited

            To reproduce (with Consul 1.8.4 or later running locally on default port):

            Consul consul = Consul.builder().build();
            System.out.println(consul.agentClient().getAgent());

            david.nault David Nault added a comment - - edited To reproduce (with Consul 1.8.4 or later running locally on default port): Consul consul = Consul.builder().build(); System.out.println(consul.agentClient().getAgent());
            david.nault David Nault added a comment -

            The structure of the http://localhost:8500/v1/agent/self response changed between 1.8.3 and 1.8.4. The debug information for logging configuration moved under a new parent node.

            david.nault David Nault added a comment - The structure of the http://localhost:8500/v1/agent/self  response changed between 1.8.3 and 1.8.4. The debug information for logging configuration moved under a new parent node.
            david.nault David Nault added a comment -

            Issue will be fixed in next consul client release. Not sure when that will be, so I'll start looking into a workaround.

            david.nault David Nault added a comment - Issue will be fixed in next consul client release. Not sure when that will be, so I'll start looking into a workaround.
            david.nault David Nault added a comment - - edited

            Workaround has been applied. Leaving issue open because the compatibility matrix in the docs still needs to be updated.

            david.nault David Nault added a comment - - edited Workaround has been applied. Leaving issue open because the compatibility matrix in the docs still needs to be updated.
            david.nault David Nault added a comment -

            Compatibility matrix has been updated.

            david.nault David Nault added a comment - Compatibility matrix has been updated.

            People

              david.nault David Nault
              david.nault David Nault
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty