Uploaded image for project: 'Couchbase Lite'
  1. Couchbase Lite
  2. CBL-1716

Update CBL .Net Core to .Net Core 3.1 (Local)

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • None
    • 3.0
    • .NET
    • Security Level: Public
    • None
    • Sandy 42
    • 3

    Description

      https://dotnet.microsoft.com/download/dotnet

      .Net Core 2.1 will be end of support on 2021-08-21 

      Requirement:

      Visual Studio 2019 (minimum visual studio v16.3) 

      Minimum C# version 7.3

      Since VS2019 is required in VMs for running .NetCore PR validation and Jenkins job, and current VMs running the jobs are low in disk space, therefore, we may need a new machine for PR validation and Jenkins job. (Added a new ticket to track this. https://issues.couchbase.com/browse/CBL-1761)

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          sandy.chuang Sandy Chuang created issue -
          sandy.chuang Sandy Chuang made changes -
          Field Original Value New Value
          Rank Ranked higher
          daniel.petersen Daniel Petersen made changes -
          Story Points 1
          daniel.petersen Daniel Petersen made changes -
          Priority Major [ 3 ] Critical [ 2 ]
          sandy.chuang Sandy Chuang made changes -
          Story Points 5
          sandy.chuang Sandy Chuang made changes -
          Assignee The Lite [ cbgto ] Sandy Chuang [ sandy.chaung ]
          sandy.chuang Sandy Chuang made changes -
          Sprint Sandy 42 [ 1487 ]
          sandy.chuang Sandy Chuang made changes -
          Rank Ranked higher
          sandy.chuang Sandy Chuang made changes -
          Description [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 
          [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 
          sandy.chuang Sandy Chuang made changes -
          Description [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 
          [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 

          Minimum C# version 7.3
          sandy.chuang Sandy Chuang made changes -
          Summary Update CBL .Net Core to .Net Core 3.1 Update CBL .Net Core to .Net Core 3.1 (Local)
          sandy.chuang Sandy Chuang made changes -
          Story Points 5 3
          sandy.chuang Sandy Chuang made changes -
          Description [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 

          Minimum C# version 7.3
          [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 

          Minimum C# version 7.3

          Since VS2019 is required in VMs for running .NetCore PR validation and Jenkins job, and current VMs running the jobs are low in disk space, therefore, we may need a new machine for PR validation and Jenkins job.
          sandy.chuang Sandy Chuang made changes -
          Description [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 

          Minimum C# version 7.3

          Since VS2019 is required in VMs for running .NetCore PR validation and Jenkins job, and current VMs running the jobs are low in disk space, therefore, we may need a new machine for PR validation and Jenkins job.
          [https://dotnet.microsoft.com/download/dotnet]

          .Net Core 2.1 will be end of support on 2021-08-21 

          Requirement:

          Visual Studio 2019 (minimum visual studio v16.3) 

          Minimum C# version 7.3

          Since VS2019 is required in VMs for running .NetCore PR validation and Jenkins job, and current VMs running the jobs are low in disk space, therefore, we may need a new machine for PR validation and Jenkins job. (Added a new ticket to track this. https://issues.couchbase.com/browse/CBL-1761)
          sandy.chuang Sandy Chuang made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          sandy.chuang Sandy Chuang made changes -
          Status In Progress [ 3 ] In Review [ 10107 ]
          sandy.chuang Sandy Chuang made changes -
          Resolution Fixed [ 1 ]
          Status In Review [ 10107 ] Resolved [ 5 ]
          sandy.chuang Sandy Chuang made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

          People

            sandy.chuang Sandy Chuang
            sandy.chuang Sandy Chuang
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty