Uploaded image for project: 'Couchbase C client library libcouchbase'
  1. Couchbase C client library libcouchbase
  2. CCBC-1202

cbc-pillowfight only loads data to default collection

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Test Blocker
    • Resolution: Fixed
    • 2.10.6
    • 3.0.1
    • library
    • None

    Description

      Observed that cbc-pillowfight loads data only to default bucket

      cbc-pillowfight -u Administrator -P password -U couchbase://10.143.192.101/bucket_1 -I 1000 -M 50 -B 100 --collection 0x8 --populate-only -J
      Populating using 10 cycles
      Running. Press Ctrl-C to terminate...
      
      

      cbstats

      root@node1-cb602-ubuntu16:/opt/couchbase/bin# ./cbstats localhost:11210 -u Administrator -p password -b bucket_1 collections
       _default:_default:id:  0x0
       collection:0x0:items:  1000
       collection:0x8:items:  0
       collection:0x9:items:  0
       collection:0xa:items:  0
       collections:           4
       default_exists:        true
       scope1:collection1:id: 0x8
       scope2:collection1:id: 0xa
       scope3:collection1:id: 0x9
       uid:                   6 

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          seeing it as a duplicate of https://issues.couchbase.com/browse/CCBC-1188 

          vikas.chaudhary Vikas Chaudhary added a comment - seeing it as a duplicate of  https://issues.couchbase.com/browse/CCBC-1188  

          working fine with latest change 

          build a docker image out of latest code

          vikass-MacBook-Pro:~ vikaschaudhary$ docker run sequoiatools/pillowfight:7.0  -u Administrator -P password -U couchbase://10.143.192.101/bucket_1 -I 1000 -M 50 -B 100 --collection scope1.collection1 --populate-only -J 

          root@node1-cb602-ubuntu16:/opt/couchbase/bin# ./cbstats localhost:11210 -u Administrator -p password -b bucket_1 collections
           _default:_default:id:  0x0
           collection:0x0:items:  0
           collection:0x8:items:  1000
           collection:0x9:items:  0
           collection:0xa:items:  0
           collections:           4
           default_exists:        true
           scope1:collection1:id: 0x8
           scope2:collection1:id: 0xa
           scope3:collection1:id: 0x9
           uid:                   6 

          vikas.chaudhary Vikas Chaudhary added a comment - working fine with latest change  build a docker image out of latest code vikass-MacBook-Pro:~ vikaschaudhary$ docker run sequoiatools/pillowfight:7.0 -u Administrator -P password -U couchbase://10.143.192.101/bucket_1 -I 1000 -M 50 -B 100 --collection scope1.collection1 --populate-only -J root@node1-cb602-ubuntu16:/opt/couchbase/bin# ./cbstats localhost:11210 -u Administrator -p password -b bucket_1 collections _default:_default:id: 0x0 collection:0x0:items: 0 collection:0x8:items: 1000 collection:0x9:items: 0 collection:0xa:items: 0 collections: 4 default_exists: true scope1:collection1:id: 0x8 scope2:collection1:id: 0xa scope3:collection1:id: 0x9 uid: 6

          People

            avsej Sergey Avseyev
            vikas.chaudhary Vikas Chaudhary
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty