Uploaded image for project: 'Couchbase Go SDK'
  1. Couchbase Go SDK
  2. GOCBC-1039

Some edge cases of collections usage causes KV_COLLECTION_OUTDATED forever

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Incomplete
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Component/s: library
    • Labels:
      None
    • Story Points:
      1

      Description

      This specifically occurs during the use of gocb with CAVES as well as FIT testing of transactions when running the RBAC tests.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          brett19 Brett Lawson added a comment -

          I think this may be caused by gocbcore not correctly updating its collections map when a collection is either created, deleted or recreated.


            People

            Assignee:
            charles.dixon Charles Dixon
            Reporter:
            brett19 Brett Lawson
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty