Uploaded image for project: 'Couchbase Java Client'
  1. Couchbase Java Client
  2. JCBC-1846

3.2.0-SNAPSHOT missing core libraries

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 3.2.0
    • 3.2.0
    • None
    • None
    • 1

    Description

      Hi, 

      We are trying to sign off on 3.2.0-SNAPSHOT and we are seeing issues compiling the code which compiled fine with previous versions i.e 3.1.5 and older ones.

      Getting the below Compilation error:

      From the error, it looks like 3.2.0-SNAPSHOT is having issues with core-io library. May be some transitive dependency issue

       

       

       
      ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/twoway/TwoWayTransaction.java:[64,30] package reactor.core.publisher does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/twoway/TwoWayTransaction.java:[65,30] package reactor.core.scheduler does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/ResultsUtil.java:[19,39] package com.couchbase.client.core.error does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/ResultsUtil.java:[20,39] package com.couchbase.client.core.error does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/ResultsUtil.java:[21,39] package com.couchbase.client.core.error does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/ResultsUtil.java:[22,39] package com.couchbase.client.core.error does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/ResultsUtil.java:[23,41] package com.couchbase.client.core.logging does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/ResultsUtil.java:[24,41] package com.couchbase.client.core.logging does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/CallCounts.java:[4,29] package reactor.util.function does not exist
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/CallCounts.java:[5,29] p*ackage reactor.util.function does not exist*
      [ERROR] /home/couchbase/jenkins/workspace/jvm/transactions/TransactionsFITPerformer_SinglePerformer/transactions-fit-performer/performers/java/txn-performer-java/src/main/java/com/couchbase/utils/CallCounts.java:[17,23] cannot find symbol
      symbol: class Tuple2
      location: class com.couchbase.utils.CallCounts

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            This issue is resolved. But hitting other issue. 

            https://issues.couchbase.com/browse/TXNJ-430

            praneeth.bokka Praneeth Bokka added a comment - This issue is resolved. But hitting other issue.  https://issues.couchbase.com/browse/TXNJ-430

            it works on local. Triggered the job on jenkins. I will update once the job completes

            http://sdk.jenkins.couchbase.com/job/jvm/job/transactions/job/TransactionsFITPerformer_SinglePerformer/584/console

            praneeth.bokka Praneeth Bokka added a comment - it works on local. Triggered the job on jenkins. I will update once the job completes http://sdk.jenkins.couchbase.com/job/jvm/job/transactions/job/TransactionsFITPerformer_SinglePerformer/584/console

            thanks David. I will try and let you know

             

            praneeth.bokka Praneeth Bokka added a comment - thanks David. I will try and let you know  
            david.nault David Nault added a comment -

            Hi Praneeth,

            We published a new snapshot with the fix. Can you try again?

            Thanks,
            David

            david.nault David Nault added a comment - Hi Praneeth, We published a new snapshot with the fix. Can you try again? Thanks, David
            david.nault David Nault added a comment - Resolved by http://review.couchbase.org/c/couchbase-jvm-clients/+/157541
            david.nault David Nault added a comment -

            Looks like a regression in d046ff08 (for JCBC-1837) which changed the `core-io` library to a "provided" dependency.

            david.nault David Nault added a comment - Looks like a regression in d046ff08 (for JCBC-1837 ) which changed the `core-io` library to a "provided" dependency.

            Given the time of day and importance here, can you have a look David Nault and pass it back to Michael Nitschinger if needed?

            ingenthr Matt Ingenthron added a comment - Given the time of day and importance here, can you have a look David Nault and pass it back to Michael Nitschinger if needed?

            People

              michael.reiche Michael Reiche
              praneeth.bokka Praneeth Bokka
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty