Uploaded image for project: 'Couchbase Kubernetes'
  1. Couchbase Kubernetes
  2. K8S-1436

Need ability to override bucket name

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.0.1
    • operator
    • None

    Description

      The way that the bucket resources are implemented is incredibly restrictive.
      Currently marked as an improvement, but I was close to moving to a bug considering this is a regression in behavior.

      For example, it's now impossible to have 2 clusters in a single namespace with the same bucket name but with different settings.
      This would be a problem in dev environments as it's often non-trivial to change bucket names within an application due to it being hardcoded in n1ql queries, connection code etc.

      A second problem is that Kubernetes metadata names have a fixed regex that does not match the regex for Couchbase buckets.
      An example here is the use of underscore, which is very popular for use in bucket names.
      Moving from 1.2 to 2.0 it's now impossible to use your old buckets which had underscores in.

      Both of these issues would be solved if there was the ability to decouple the bucket name from the name of the Kubernetes resource.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            simon.murray Simon Murray added a comment -

            Wondered how long it would take for you to moan about this   I'll have spec.name override metadata.name if set.

            simon.murray Simon Murray added a comment - Wondered how long it would take for you to moan about this   I'll have spec.name override metadata.name if set.
            simon.murray Simon Murray added a comment -

            2.0.1 I take it if it's going to be a problem for lots of people?

            simon.murray Simon Murray added a comment - 2.0.1 I take it if it's going to be a problem for lots of people?

            Yeah, first maintenance release of 2.x is probably about right

            matt.carabine Matt Carabine added a comment - Yeah, first maintenance release of 2.x is probably about right

            One additional consideration, would cbopconv in 2.0.1 be able to handle this?
            Today, it errors out because the old bucket name produces an invalid metadata.name, it would be nice if cbopconv could detect this situation and set spec.name if metadata.name did not match the regex.

            matt.carabine Matt Carabine added a comment - One additional consideration, would cbopconv in 2.0.1 be able to handle this? Today, it errors out because the old bucket name produces an invalid metadata.name, it would be nice if cbopconv could detect this situation and set spec.name if metadata.name did not match the regex.

            I'll just play it safe and generate an ephemeral names, keep it consistent.

            simon.murray Simon Murray added a comment - I'll just play it safe and generate an ephemeral names, keep it consistent.

            People

              simon.murray Simon Murray
              matt.carabine Matt Carabine
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty