The enemy of all refactoring... and kinda my fault. The original `targetKube` name I don't like, preferring `kubernetes` as it's more descriptive. Problem is we have the same thing referred to a different names. We should standardize on...
- kubernetes - a kubernetes cluster
- cluster or couchbase - a couchbase cluster