Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-22437

[Query Workbench UI] : Issues with Query Editor Preferences dialog

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.0
    • Fix Version/s: 5.0.0
    • Component/s: UI
    • Labels:
      None
    • Triage:
      Untriaged
    • Is this a Regression?:
      Unknown

      Description

      On the Query Workbench UI, there is a 'Settings'/Preferences icon next to the heading Query Editor. Clicking this one brings up the Query Editor Preferences dialog. There are some issues with this dialog.

      1. Arrangement of controls on the Query Editor Preferences dialog is not proper
      2. No tooltip for the icon on the Query Editor heading
      3. The icon for Query Editor Preferences should be aligned with the heading Query Editor
      4. The dialog has no heading

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          mikew Mike Wiederhold added a comment -

          I believe this was temporarily by design and that Eben is currently making it look nicer.

          eben Eben Haber added a comment -

          Indeed it is a temporary design to make the functionality available, and it's waiting for Rob to have time to make it consistent with the other dialogs.

          rob.ashcom Rob Ashcom added a comment -

          Show
          rob.ashcom Rob Ashcom added a comment -
          mihir.kamdar Mihir Kamdar added a comment -

          Verified on build 5.0.0-2837


            People

            • Assignee:
              rob.ashcom Rob Ashcom
              Reporter:
              mihir.kamdar Mihir Kamdar
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.