Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-34646

CB collect breaks with import error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.5.0
    • Fix Version/s: 6.5.0
    • Component/s: test-execution
    • Labels:
      None
    • Environment:
      Enterprise Edition 6.5.0 build 3526
    • Triage:
      Untriaged
    • Operating System:
      Centos 64-bit
    • Is this a Regression?:
      Yes

      Description

      1. Navigate to 'Collect Information'
      2. Choose to "Collect Logs and Diagnostic Information"
      3. Choose "upload to couchbase"
      4. choose host too upload logs - 
      5. Enter Customer name
      6. Start Collection

       

      Collection fails with following error:

       

       
      Logs are being uploaded from these paths:
      10.112.190.102 /opt/couchbase/var/lib/couchbase/tmp/collectinfo-2019-06-18T142753-ns_1@10.112.190.102.zip
      Error: Unable to collect logs from the following nodes:
      10.112.190.101
      Node errors:
      10.112.190.101
      Traceback (most recent call last): File "/opt/couchbase/lib/python/cbcollect_info", line 32, in <module> import urllib.request, urllib.parse, urllib.error File "/opt/couchbase/lib/python/runtime/lib/python3.7/urllib/request.py", line 84, in <module> import base64 File "/opt/couchbase/lib/python/runtime/lib/python3.7/base64.py", line 11, in <module> import binascii ImportError: /opt/couchbase/lib/python/runtime/lib/python3.7/lib-dynload/../../libz.so.1: file too short

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          ritam.sharma Ritam Sharma added a comment -

          Cannot collect logs via collect command line as well

          [root@node1-cb600-centos7 bin]# ./cbcollect_info 101.zip

          Traceback (most recent call last):

            File "/opt/couchbase/lib/python/cbcollect_info", line 32, in <module>

              import urllib.request, urllib.parse, urllib.error

            File "/opt/couchbase/lib/python/runtime/lib/python3.7/urllib/request.py", line 84, in <module>

              import base64

            File "/opt/couchbase/lib/python/runtime/lib/python3.7/base64.py", line 11, in <module>

              import binascii

          ImportError: /opt/couchbase/lib/python/runtime/lib/python3.7/lib-dynload/../../libz.so.1: file too short

          dfinlay Dave Finlay added a comment -

          Hi Ritam - some quickly googling reveals this is probably a problem with your VM or docker instance where you're running the collect. Can you check to see if the file is present and has a reasonable length? The trying removing and reinstalling zlib. If the problem persists can you provide access to the VM and we'll take a closer look.

          ritam.sharma Ritam Sharma added a comment -

          Dave Finlay - libz.so - is coming from -  /opt/couchbase/lib/python/runtime/lib/python3.7/lib-dynload/../../libz.so.1 - This is from couchbase install.

          ritam.sharma Ritam Sharma added a comment -

          Lowering the priority of the defects, since it happens on my vagrants

          ritam.sharma Ritam Sharma added a comment -

          Cannot reproduce this latest builds on my vagrants. Closing the issue.


            People

            Assignee:
            ritam.sharma Ritam Sharma
            Reporter:
            ritam.sharma Ritam Sharma
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty