Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-36318

xdcr.uniXDCR.unidirectional is broken

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Test Blocker
    • Resolution: Duplicate
    • 6.5.0
    • 6.5.0
    • XDCR
    • None
    • Untriaged
    • Unknown

    Description

      See here:
      http://cv.jenkins.couchbase.com/job/ns-server-simple-test/1184/console

      Looks like goxdcr refuses http connection:

      [ns_server:error,2019-10-03T15:02:19.491-07:00,n_0@127.0.0.1:<0.25244.6>:menelaus_web:loop:163]Server error during processing: ["web request failed",
                                       {path,"/pools/default/remoteClusters/"},
                                       {method,'GET'},
                                       {type,error},
                                       {what,
                                        {badmatch,
                                         {error,
                                          {econnrefused,
                                           [{lhttpc_client,send_request,1,
                                             [{file,
                                               "/home/couchbase/jenkins/workspace/ns-server-simple-test/couchdb/src/lhttpc/lhttpc_client.erl"},
                                              {line,220}]},
                                            {lhttpc_client,execute,9,
                                             [{file,
                                               "/home/couchbase/jenkins/workspace/ns-server-simple-test/couchdb/src/lhttpc/lhttpc_client.erl"},
                                              {line,169}]},
                                            {lhttpc_client,request,9,
                                             [{file,
                                               "/home/couchbase/jenkins/workspace/ns-server-simple-test/couchdb/src/lhttpc/lhttpc_client.erl"},
                                              {line,92}]}]}}}},
                                       {trace,
                                        [{goxdcr_rest,send_with_timeout,5,
                                          [{file,"src/goxdcr_rest.erl"},{line,56}]},
                                         {goxdcr_rest,proxy,2,
                                          [{file,"src/goxdcr_rest.erl"},{line,85}]},
                                         {request_throttler,do_request,3,
                                          [{file,"src/request_throttler.erl"},
                                           {line,59}]},
                                         {menelaus_web,loop,2,
                                          [{file,"src/menelaus_web.erl"},
                                           {line,141}]},
                                         {mochiweb_http,headers,5,
                                          [{file,
                                            "/home/couchbase/jenkins/workspace/ns-server-simple-test/couchdb/src/mochiweb/mochiweb_http.erl"},
                                           {line,94}]},
                                         {proc_lib,init_p_do_apply,3,
                                          [{file,"proc_lib.erl"},{line,247}]}]}]
      

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          It looks like goxdcr crashed right after creating the replication:

          [user:info,2019-10-03T15:02:09.401-07:00,n_0@127.0.0.1:<0.24830.6>:xdcr:unknown:-1]Replication from bucket "default" to bucket "default" on cluster "remote_cluster_C1-C2" created.
          [user:info,2019-10-03T15:02:09.597-07:00,n_0@127.0.0.1:<0.1783.0>:ns_log:crash_consumption_loop:69]Service 'goxdcr' exited with status 2. Restarting. Messages:
          , 0x0)
          	/home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1077 +0x58f
          github.com/couchbase/goxdcr/parts.(*DcpNozzle).startUprStream(0xc0003681e0, 0x10013, 0xc0000b8d20, 0x0, 0x0)
          	/home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1095 +0x93
          github.com/couchbase/goxdcr/parts.(*DcpNozzle).startUprStreams_internal(0xc0003681e0, 0xc000a20400, 0x100, 0x100, 0x100, 0x100)
          	/home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1045 +0xdb
          github.com/couchbase/goxdcr/parts.(*DcpNozzle).startUprStreams(0xc0003681e0, 0x0, 0x0)
          	/home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1005 +0x30a
          created by github.com/couchbase/goxdcr/parts.(*DcpNozzle).Start
          	/home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:628 +0x421
          
          

          artem Artem Stemkovski added a comment - It looks like goxdcr crashed right after creating the replication: [user:info,2019-10-03T15:02:09.401-07:00,n_0@127.0.0.1:<0.24830.6>:xdcr:unknown:-1]Replication from bucket "default" to bucket "default" on cluster "remote_cluster_C1-C2" created. [user:info,2019-10-03T15:02:09.597-07:00,n_0@127.0.0.1:<0.1783.0>:ns_log:crash_consumption_loop:69]Service 'goxdcr' exited with status 2. Restarting. Messages: , 0x0) /home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1077 +0x58f github.com/couchbase/goxdcr/parts.(*DcpNozzle).startUprStream(0xc0003681e0, 0x10013, 0xc0000b8d20, 0x0, 0x0) /home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1095 +0x93 github.com/couchbase/goxdcr/parts.(*DcpNozzle).startUprStreams_internal(0xc0003681e0, 0xc000a20400, 0x100, 0x100, 0x100, 0x100) /home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1045 +0xdb github.com/couchbase/goxdcr/parts.(*DcpNozzle).startUprStreams(0xc0003681e0, 0x0, 0x0) /home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:1005 +0x30a created by github.com/couchbase/goxdcr/parts.(*DcpNozzle).Start /home/couchbase/jenkins/workspace/ns-server-simple-test/goproj/src/github.com/couchbase/goxdcr/parts/dcp_nozzle.go:628 +0x421
          neil.huang Neil Huang added a comment -

          Duplicate of MB-36327

          neil.huang Neil Huang added a comment - Duplicate of MB-36327

          closing duplicate

          pavithra.mahamani Pavithra Mahamani added a comment - closing duplicate

          People

            neil.huang Neil Huang
            artem Artem Stemkovski
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty