Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-36873

HTTP 500 - /engageCluster2 - After enabling x509 certs on the cluster

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Duplicate
    • 6.5.0
    • 6.5.0
    • ns_server
    • Enterprise Edition 6.5.0 build 4790 ‧ IPv4

    Description

      1. Enable x509 certs for a cluster. Add node certs to all other nodes
      2. Add node to the cluster.
      Rebalance fails:
      Failed to add node 172.23.107.7:8091 to cluster. Prepare join failed. Got HTTP status 500 from REST call post to http://172.23.107.7:8091/engageCluster2. Body was: "[\"Unexpected server error, request logged.\"]"

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          ritam.sharma Ritam Sharma added a comment -

          Regression from https://issues.couchbase.com/browse/MB-36710.
          Last good build - 6.5.0-4783

          ritam.sharma Ritam Sharma added a comment - Regression from https://issues.couchbase.com/browse/MB-36710 . Last good build - 6.5.0-4783
          dfinlay Dave Finlay added a comment -

          Is a dupe of MB-36866. Will resolve this one and set the other as blocker.

          ** Reason for termination ==
          ** {{badmatch,{error,enoent}},
              [{ns_ssl_services_setup,handle_call,3,
                                      [{file,"src/ns_ssl_services_setup.erl"},
                                       {line,506}]},
               {gen_server,try_handle_call,4,[{file,"gen_server.erl"},{line,636}]},
               {gen_server,handle_msg,6,[{file,"gen_server.erl"},{line,665}]},
               {proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,247}]}]}
          

          CC: Timofey Barmin

          dfinlay Dave Finlay added a comment - Is a dupe of MB-36866. Will resolve this one and set the other as blocker. ** Reason for termination == ** {{badmatch,{error,enoent}}, [{ns_ssl_services_setup,handle_call,3, [{file,"src/ns_ssl_services_setup.erl"}, {line,506}]}, {gen_server,try_handle_call,4,[{file,"gen_server.erl"},{line,636}]}, {gen_server,handle_msg,6,[{file,"gen_server.erl"},{line,665}]}, {proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,247}]}]} CC: Timofey Barmin

          People

            dfinlay Dave Finlay
            ritam.sharma Ritam Sharma
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty