Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-37329

Expelling of items from checkpoints is non-optimal

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate
    • 6.5.0
    • 6.5.1
    • couchbase-bucket
    • None
    • Triaged
    • No

    Description

      The checkpoint expelling code added in Mad-Hatter can fail to expel an item from a Checkpoint if there's only 1 candidate item to expel.
      This can result in increased memory usage (see MB-37294), which is more significant for large Documents / small memory quotas.
      (Separated out from MB-37294.)

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            owend Daniel Owen created issue -
            owend Daniel Owen made changes -
            Field Original Value New Value
            Fix Version/s 6.5.1 [ 16622 ]
            owend Daniel Owen made changes -
            Triage Untriaged [ 10351 ] Triaged [ 10350 ]
            owend Daniel Owen made changes -
            Is this a Regression? Unknown [ 10452 ] No [ 10451 ]
            owend Daniel Owen made changes -
            Link This issue relates to MB-37294 [ MB-37294 ]
            owend Daniel Owen made changes -
            Description ..to do.. The checkpoint expelling code added in Mad-Hatter can fail to expel an item from a Checkpoint if there's only 1 candidate item to expel.
            This can result in increased memory usage (see MB-37294), which is more significant for large Documents / small memory quotas.
            (Separated out from MB-37294.)
            owend Daniel Owen added a comment -

            Duplicate of MB-37330

            owend Daniel Owen added a comment - Duplicate of MB-37330
            owend Daniel Owen made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            owend Daniel Owen made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            wayne Wayne Siu made changes -
            Link This issue is duplicated by MB-37330 [ MB-37330 ]

            People

              owend Daniel Owen
              owend Daniel Owen
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty