Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-37750

cbbackupmgr logs then ignores errors from the storage layer

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Duplicate
    • 6.0.3
    • 6.5.0
    • tools
    • None
    • Untriaged
    • No

    Description

      During a backup when getting errors from the storage layer e.g. a failed write (caused by the mutation/deletion callback in dcp.go) they will be logged, however, we simply ignore them and continue trucking. This is the wrong behavior; we should at the very least evaluate the errors and exit if they are serious.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            james.lee James Lee created issue -
            james.lee James Lee made changes -
            Field Original Value New Value
            Link This issue relates to CBSE-7863 [ CBSE-7863 ]

            James Lee the affected version should be 6.0.3 based on CBSE-7863?

            arunkumar Arunkumar Senthilnathan added a comment - James Lee the affected version should be 6.0.3 based on CBSE-7863?
            james.lee James Lee made changes -
            Affects Version/s 6.0.3 [ 16164 ]
            Affects Version/s 6.0.4 [ 16502 ]
            james.lee James Lee added a comment -

            Thanks Arunkumar Senthilnathan, you're correct, I've changed the affected version to 6.0.3.

            james.lee James Lee added a comment - Thanks Arunkumar Senthilnathan , you're correct, I've changed the affected version to 6.0.3.
            owend Daniel Owen made changes -
            Fix Version/s 6.5.1 [ 16622 ]
            owend Daniel Owen made changes -
            Labels 6.0.5-candidate
            lynn.straus Lynn Straus made changes -
            Link This issue blocks MB-37192 [ MB-37192 ]
            lynn.straus Lynn Straus added a comment -

            approved for 6.5.1 per Feb 3 maintenance meeting

            lynn.straus Lynn Straus added a comment - approved for 6.5.1 per Feb 3 maintenance meeting
            owend Daniel Owen made changes -
            Fix Version/s 6.5.1 [ 16622 ]
            owend Daniel Owen made changes -
            Labels 6.0.5-candidate
            owend Daniel Owen added a comment -

            Is a duplicate of MB-24734

            owend Daniel Owen added a comment - Is a duplicate of  MB-24734
            owend Daniel Owen made changes -
            Fix Version/s Mad-Hatter [ 15037 ]
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            owend Daniel Owen added a comment -

            Will remove from the approved for 6.5.1 list(as the duplicate MB is already in MH)

            owend Daniel Owen added a comment - Will remove from the approved for 6.5.1 list(as the duplicate MB is already in MH)
            owend Daniel Owen made changes -
            Link This issue blocks MB-37192 [ MB-37192 ]
            owend Daniel Owen made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            owend Daniel Owen made changes -
            Link This issue duplicates MB-24734 [ MB-24734 ]

            People

              james.lee James Lee
              james.lee James Lee
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty