Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-39442

[BucketDurability-UI]: Unable to create Ephemeral bucket with durability level=MAJORITY

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 6.6.0
    • 6.6.0
    • UI
    • Enterprise Edition 6.6.0 build 7651
    • Untriaged
    • Centos 64-bit
    • 1
    • No

    Description

      Build: 6.6.0-7651

      There is no Durability option available for Ephemeral bucket, even though we can perform

      syncWrites with durability=MAJORITY from 6.5 release.

      Attachments

        Issue Links

          For Gerrit Dashboard: MB-39442
          # Subject Branch Project Status CR V

          Activity

            Build couchbase-server-6.6.0-7680 contains ns_server commit 7b28c7a with commit message:
            MB-39442: add durability level to Ephemeral bucket config

            build-team Couchbase Build Team added a comment - Build couchbase-server-6.6.0-7680 contains ns_server commit 7b28c7a with commit message: MB-39442 : add durability level to Ephemeral bucket config

            Build couchbase-server-7.0.0-2144 contains ns_server commit 7b28c7a with commit message:
            MB-39442: add durability level to Ephemeral bucket config

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.0-2144 contains ns_server commit 7b28c7a with commit message: MB-39442 : add durability level to Ephemeral bucket config

            Verified on Enterprise Edition 6.6.0 build 7687.

            Ephemeral bucket supports creating bucket with durability_level MAJORITY alone.

            ashwin.govindarajulu Ashwin Govindarajulu added a comment - Verified on Enterprise Edition 6.6.0 build 7687. Ephemeral bucket supports creating bucket with durability_level MAJORITY alone.

            Install 6.6.2 CB version and try the scenario : I can not change the durability level as explained previously.

            fabrice.leray Fabrice Leray added a comment - Install 6.6.2 CB version and try the scenario : I can not change the durability level as explained previously.

            I will have a look

            pavel Pavel Blagodov added a comment - I will have a look

            Fabrice Leray, thank you for report. I'm going to open separate ticket for 6.6.4 where we address this issue.

            pavel Pavel Blagodov added a comment - Fabrice Leray , thank you for report. I'm going to open separate ticket for 6.6.4 where we address this issue.

            People

              pavel Pavel Blagodov
              ashwin.govindarajulu Ashwin Govindarajulu
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty