Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-40214

non-root install script does not work with ubuntu18

    XMLWordPrintable

    Details

    • Triage:
      Untriaged
    • Story Points:
      1
    • Is this a Regression?:
      No

      Description

      Steps:

      1. Login as nonroot user to a ubuntu18 machine
      2. Download ubunut18 deb package for 6.6
      3. git clone non root install script
      4. mkdir ~/couchbase-home
      5. cd into non root install script directory
      6. Run command to install:

      ubuntu@ip-172-31-17-221:~/cb-non-package-installer$ ./cb-non-package-installer --install --install-location ../couchbase-home --package ../couchbase-server-enterprise_6.6.0-7853-ubuntu18.04_amd64.deb
      2020/06/30T04:51:49 ERROR: Cannot install Couchbase Server missing dependency: " libc6 (>= 2.27)"

      7. Check to ensure libc6 is installed:

      ubuntu@ip-172-31-17-221:~$ dpkg -l | grep libc6
      ii libc6:arm64 2.27-3ubuntu1 arm64 GNU C Library: Shared libraries

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          arunkumar Arunkumar Senthilnathan created issue -
          arunkumar Arunkumar Senthilnathan made changes -
          Field Original Value New Value
          Component/s build [ 10200 ]
          arunkumar Arunkumar Senthilnathan made changes -
          Resolution User Error [ 10100 ]
          Status Open [ 1 ] Resolved [ 5 ]
          arunkumar Arunkumar Senthilnathan made changes -
          Fix Version/s 6.6.0 [ 16787 ]
          arunkumar Arunkumar Senthilnathan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          arunkumar Arunkumar Senthilnathan made changes -
          Resolution User Error [ 10100 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          arunkumar Arunkumar Senthilnathan made changes -
          Component/s build [ 10200 ]
          arunkumar Arunkumar Senthilnathan made changes -
          Description Steps:

          1. Login as nonroot user to a ubuntu18 machine
          2. Download ubunut18 deb package for 6.6
          3. git clone non root install script
          4. Run command to install:

          nonroot@ubuntu:~/cb-non-package-installer$ ./cb-non-package-installer --install --install-location /home/nonroot/ --package /home/nonroot/couchbase-server-enterprise-dbg_6.6.0-7853-ubuntu18.04_amd64.deb
          2020/06/29T17:26:00 ERROR: Cannot install Couchbase Server missing dependency: " couchbase-server (= 6.6.0-7853-1)"
          Steps:

          1. Login as nonroot user to a ubuntu18 machine
          2. Download ubunut18 deb package for 6.6
          3. git clone non root install script
          4. mkdir ~/couchbase-home
          5. cd into non root install script directory
          6. Run command to install:

          ubuntu@ip-172-31-17-221:~/cb-non-package-installer$ ./cb-non-package-installer --install --install-location ../couchbase-home --package ../couchbase-server-enterprise_6.6.0-7853-ubuntu18.04_amd64.deb
          2020/06/30T04:51:49 ERROR: Cannot install Couchbase Server missing dependency: " libc6 (>= 2.27)"

          7. Check to ensure libc6 is installed:

          ubuntu@ip-172-31-17-221:~$ dpkg -l | grep libc6
          ii libc6:arm64 2.27-3ubuntu1 arm64 GNU C Library: Shared libraries
          arunkumar Arunkumar Senthilnathan made changes -
          Comment [ So the script uses dpkg --info to figure out dependencies and for some reason couchbase-server (= 6.6.0-7853-1) is listed as a dependency:

          nonroot@ubuntu:~$ dpkg --info couchbase-server-enterprise-dbg_6.6.0-7853-ubuntu18.04_amd64.deb
           new Debian package, version 2.0.
           size 189631720 bytes: control archive=20480 bytes.
               564 bytes, 16 lines control
             12680 bytes, 148 lines md5sums
           Package: couchbase-server-dbg
           Source: couchbase-server
           Version: 6.6.0-7853-1
           Architecture: amd64
           Maintainer: Couchbase <support@couchbase.com>
           Installed-Size: 739500
           *Depends: couchbase-server (= 6.6.0-7853-1)*
           Section: debug
           Priority: extra
           Homepage: http://couchbase.com
           Description: debugging symbols for couchbase-server
            Couchbase Server is the leading distribution of memcached and
            couchbase, created and supported by top contributors to the memcached
            and couchbase open source projects.
            .
            This package contains the debugging symbols for couchbase-server.

          So this might be a build bug ]
          arunkumar Arunkumar Senthilnathan made changes -
          Comment [ Downloaded dbg build by mistake ]
          arunkumar Arunkumar Senthilnathan made changes -
          Fix Version/s 6.6.0 [ 16787 ]
          arunkumar Arunkumar Senthilnathan added a comment -
          arunkumar Arunkumar Senthilnathan added a comment -

          With the fix, now running into this issue:

          ubuntu@ip-172-31-17-221:~/cb-non-package-installer$ ./cb-non-package-installer --install --install-location ../couchbase-home --package ../couchbase-server-enterprise_6.6.0-7853-ubuntu18.04_amd64.deb -vvvv
          2020/06/30T05:02:23 DEBUG: Checking if command 'dpkg' is available
          2020/06/30T05:02:23 DEBUG: Checking if command 'perl' is available
          2020/06/30T05:02:24 DEBUG: Checking if command 'bzip2' is available
          2020/06/30T05:02:24 DEBUG: Checking if command 'tar' is available
          2020/06/30T05:02:24 INFO: Installing Couchbase Server
          2020/06/30T05:02:24 DEBUG: Unpacking /home/ubuntu/couchbase-server-enterprise_6.6.0-7853-ubuntu18.04_amd64.deb
          2020/06/30T05:02:53 DEBUG: Executing reloc.sh
          2020/06/30T05:03:03 ERROR: Problems executing reloc.sh
          ubuntu@ip-172-31-17-221:~/cb-non-package-installer$

          arunkumar Arunkumar Senthilnathan made changes -
          Is this a Regression? Unknown [ 10452 ] No [ 10451 ]
          arunkumar Arunkumar Senthilnathan added a comment -

          Tested on an aws instance - can provide creds if needed

          pvarley Patrick Varley added a comment - - edited

          With your fix, I can't reproduce the second issue with the vagrant machines. You got the creds and have a look at that machine.

          arunkumar Arunkumar Senthilnathan added a comment - - edited

          Had a quick chat with Patrick Varley - happens consistently in my aws ubuntu18 env - gave access to the machine to debug further

          build-team Couchbase Build Team added a comment -

          Build python_tools::cb-non-package-installer-6.6.0-4 contains cb-non-package-installer commit ee3d16b with commit message:
          MB-40214 fixing the missing dependency issue for deb packages

          arunkumar Arunkumar Senthilnathan added a comment -

          Seeing the same issue with suse15 on aws as well:

          ec2-user@ip-172-31-18-17:~/cb-non-package-installer> ./cb-non-package-installer --install --install-location ../couchbase-home --package ../couchbase-server-enterprise-6.6.0-7853-suse15.x86_64.rpm
          warning: ../couchbase-server-enterprise-6.6.0-7853-suse15.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID cd406e62: NOKEY
          2020/06/30T19:51:57 ERROR: Problems executing reloc.sh

          pvarley Patrick Varley added a comment -

          ubuntu@ip-172-31-17-221:~$ dpkg -l | grep libc6
          ii libc6:arm64 2.27-3ubuntu1 arm64 GNU C Library: Shared libraries

          That is arm64 instance, Couchbase-server only runs on amd64 currently.

          arunkumar Arunkumar Senthilnathan added a comment -

          The second issue turned out to be user error - I was using ARM instances (switched from intel when I hit the first issue as I was debugging and never went back) - works fine now with my fix on ubuntu18:

          ubuntu@ip-172-31-45-222:~/cb-non-package-installer$ ./cb-non-package-installer --install --install-location ../couchbase-home --package ../couchbase-server-enterprise_6.6.0-7853-ubuntu18.04_amd64.deb
          Successfully installed
          ubuntu@ip-172-31-45-222:~/cb-non-package-installer$

          arunkumar Arunkumar Senthilnathan made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          owend Daniel Owen made changes -
          Assignee Patrick Varley [ pvarley ] Arunkumar Senthilnathan [ arunkumar ]
          till Till Westmann made changes -
          Link This issue blocks MB-38724 [ MB-38724 ]
          till Till Westmann made changes -
          Labels manual_testing approved-for-6.6.0 manual_testing
          arunkumar Arunkumar Senthilnathan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            Assignee:
            arunkumar Arunkumar Senthilnathan
            Reporter:
            arunkumar Arunkumar Senthilnathan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty