Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-40237

non-root install script throws error in ubuntu16

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: User Error
    • Affects Version/s: 6.6.0
    • Fix Version/s: 6.6.0
    • Component/s: tools
    • Labels:
    • Triage:
      Triaged
    • Story Points:
      1
    • Is this a Regression?:
      Unknown

      Description

      Steps:

      1. Login as nonroot user to a ubuntu16 aws machine
      2. git clone non root install script
      3. Try to run help on the script:

      ubuntu@ip-172-31-43-238:~/cb-non-package-installer$ ./cb-non-package-installer -h
      File "./cb-non-package-installer", line 58
      error(f'Could not get version from Package name

      {package}

      ')
      ^
      SyntaxError: invalid syntax

      Environment:

      ubuntu@ip-172-31-43-238:~/cb-non-package-installer$ uname -a
      Linux ip-172-31-43-238 4.4.0-1109-aws #120-Ubuntu SMP Fri Jun 5 01:26:57 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
      ubuntu@ip-172-31-43-238:~/cb-non-package-installer$ cat /etc/*elease
      DISTRIB_ID=Ubuntu
      DISTRIB_RELEASE=16.04
      DISTRIB_CODENAME=xenial
      DISTRIB_DESCRIPTION="Ubuntu 16.04.6 LTS"
      NAME="Ubuntu"
      VERSION="16.04.6 LTS (Xenial Xerus)"
      ID=ubuntu
      ID_LIKE=debian
      PRETTY_NAME="Ubuntu 16.04.6 LTS"
      VERSION_ID="16.04"
      HOME_URL="http://www.ubuntu.com/"
      SUPPORT_URL="http://help.ubuntu.com/"
      BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
      VERSION_CODENAME=xenial
      UBUNTU_CODENAME=xenial

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          arunkumar Arunkumar Senthilnathan added a comment -

          works fine with python3.8

          pvarley Patrick Varley added a comment -

          This is because version of python3 on ubuntu16 is too old and does not support f-format strings. This is why the binary version of the script is built so it does not depend on any versionof pyhon. Please try it the binary version from the latest build.


            People

            Assignee:
            pvarley Patrick Varley
            Reporter:
            arunkumar Arunkumar Senthilnathan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty