Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-40708

Add note that client cert auth is (currently) only supported for GSuite Secure LDAP

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 6.6.0
    • Fix Version/s: 6.6.0
    • Component/s: UI
    • Triage:
      Untriaged
    • Story Points:
      1
    • Is this a Regression?:
      Unknown

      Description

      We need to add a note to the UI that client cert auth for LDAP currently only works for GSuite Secure LDAP and not all LDAPs. (The plan is to fix this for 6.6.1).

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          rob.ashcom Rob Ashcom added a comment -

          The issue here was that there are 2 somewhat competing messages for Client Cert:  the disabled because of no encryption msg and this new one for when client cert is selected.

          The existing msg should have been conditional on the encryption thing; the new msg is conditional on the selection of client cert which can’t happen until the first condition is met anyhow – so no collision.

          rob.ashcom Rob Ashcom added a comment -

          The first three attached screenshots show how it should look as the UI states change.

          build-team Couchbase Build Team added a comment -

          Build couchbase-server-6.6.0-7902 contains ns_server commit d2c4685 with commit message:
          MB-40708: add note that LDAP client certs only work with ...

          build-team Couchbase Build Team added a comment -

          Build couchbase-server-7.0.0-2738 contains ns_server commit d2c4685 with commit message:
          MB-40708: add note that LDAP client certs only work with ...

          ritam.sharma Ritam Sharma added a comment -

          Verified and closed for 6.6.0-7902. Warning message in UI only appears when Client Cert is selected.


            People

            Assignee:
            dfinlay Dave Finlay
            Reporter:
            dfinlay Dave Finlay
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty