Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-41643

BP 6.6.1 MB-37225 Panic in indexer logs while running GSI performance experiments

    XMLWordPrintable

    Details

    • Triage:
      Untriaged
    • Story Points:
      1
    • Is this a Regression?:
      Unknown

      Description

      Backport of MB-37225

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

            srinath.duvuru Srinath Duvuru created issue -
            srinath.duvuru Srinath Duvuru made changes -
            Field Original Value New Value
            Link This issue relates to MB-37225 [ MB-37225 ]
            wayne Wayne Siu made changes -
            Link This issue blocks MB-40528 [ MB-40528 ]
            wayne Wayne Siu made changes -
            Link This issue is a backport of MB-37225 [ MB-37225 ]
            wayne Wayne Siu made changes -
            Link This issue relates to MB-37225 [ MB-37225 ]
            wayne Wayne Siu made changes -
            Labels plasma approved-for-6.6.1 plasma
            srinath.duvuru Srinath Duvuru made changes -
            Assignee Srinath Duvuru [ srinath.duvuru ] Akhil Mundroy [ akhil.mundroy ]
            build-team Couchbase Build Team added a comment -

            Build couchbase-server-6.6.1-9101 contains plasma commit da98bd4 with commit message:
            MB-41643 [BP]: Avoid divide-by-zero on ReclaimListSize < ReclaimListCount

            akhil.mundroy Akhil Mundroy made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            girish.benakappa Girish Benakappa made changes -
            Comment [ Hi [~akhil.mundroy]

            if this needs QE Verification, Can you please update the steps to reproduce and verify this issue?
            ]
            girish.benakappa Girish Benakappa made changes -
            Labels approved-for-6.6.1 plasma Performance approved-for-6.6.1 plasma
            mihir.kamdar Mihir Kamdar added a comment -

            Akhil Mundroy Srinath Duvuru is any functional testing possible for this fix ? Or should we validate it based on the perf test that caught this issue ?

            srinath.duvuru Srinath Duvuru added a comment -

            Akhil Mundroy was able to reproduce it by some code instrumentation. It may be hard to do it with functional test. The fix is safe and using the perf test to validate should be enough.

            ritam.sharma Ritam Sharma made changes -
            Labels Performance approved-for-6.6.1 plasma Performance approved-for-6.6.1 plasma request-dev-verify
            akhil.mundroy Akhil Mundroy added a comment -

            Closing since it has not been reported again in any of the perf test runs.

            akhil.mundroy Akhil Mundroy made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              akhil.mundroy Akhil Mundroy
              Reporter:
              srinath.duvuru Srinath Duvuru
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes

                    PagerDuty