Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-41968

[CX] Internal error when creating a dataset without a name

    XMLWordPrintable

    Details

    • Triage:
      Untriaged
    • Story Points:
      1
    • Is this a Regression?:
      Unknown
    • Sprint:
      CX Sprint 221, CX Sprint 222

      Description

      When creating a dataset without a name, e.g.

      CREATE DATASET `Default`.``
        ON `beer-sample`
        AT `Default`.`other`
        WHERE `type`="beer";
      

      we get an internal error

      2020-10-10T17:42:58.794-07:00 WARN CBAS.server.QueryServiceServlet [HttpExecutor(port:9600)-8] handleException: unexpected exception java.lang.IllegalStateException: Unrecognized path structure: storage/partition_0/Default/0/.metadata: <ud>{"host":"localhost:9000","path":"/query/service","statement":"CREATE  DATASET `Default`.`` ON `beer-sample` at `Default`.`other` WHERE `type`=\\\"beer\\\"","pretty":false,"mode":"immediate","clientContextID":null,"format":"CLEAN_JSON","timeout":9223372036854775807,"maxResultReads":1,"planFormat":"JSON","expressionTree":false,"rewrittenExpressionTree":false,"logicalPlan":false,"optimizedLogicalPlan":false,"job":false,"profile":"counts","signature":true,"multiStatement":false,"parseOnly":false,"readOnly":false,"maxWarnings":0,"scanConsistency":null,"scanWait":null}</ud>
      org.apache.hyracks.api.exceptions.HyracksDataException: java.lang.IllegalStateException: Unrecognized path structure: storage/partition_0/Default/0/.metadata
      	at org.apache.hyracks.api.exceptions.HyracksDataException.create(HyracksDataException.java:51) ~[hyracks-api.jar:6.6.0-0000]
      	at org.apache.hyracks.api.rewriter.runtime.SuperActivityOperatorNodePushable.runInParallel(SuperActivityOperatorNodePushable.java:251) ~[hyracks-api.jar:6.6.0-0000]
      	at org.apache.hyracks.api.rewriter.runtime.SuperActivityOperatorNodePushable.initialize(SuperActivityOperatorNodePushable.java:91) ~[hyracks-api.jar:6.6.0-0000]
      	at org.apache.hyracks.control.nc.Task.run(Task.java:320) ~[hyracks-control-nc.jar:6.6.0-0000]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:?]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:?]
      	at java.lang.Thread.run(Unknown Source) [?:?]
      	Suppressed: org.apache.hyracks.api.exceptions.HyracksDataException: HYR0104: Index does not exist
      		at org.apache.hyracks.api.exceptions.HyracksDataException.create(HyracksDataException.java:60) ~[hyracks-api.jar:6.6.0-0000]
      		at org.apache.hyracks.storage.am.common.dataflow.IndexDataflowHelper.readIndex(IndexDataflowHelper.java:76) ~[hyracks-storage-am-common.jar:6.6.0-0000]
      		at org.apache.hyracks.storage.am.common.dataflow.IndexDataflowHelper.destroy(IndexDataflowHelper.java:98) ~[hyracks-storage-am-common.jar:6.6.0-0000]
      		at org.apache.hyracks.storage.am.common.dataflow.IndexDropOperatorNodePushable.dropIndex(IndexDropOperatorNodePushable.java:82) ~[hyracks-storage-am-common.jar:6.6.0-0000]
      		at org.apache.hyracks.storage.am.common.dataflow.IndexDropOperatorNodePushable.initialize(IndexDropOperatorNodePushable.java:71) ~[hyracks-storage-am-common.jar:6.6.0-0000]
      		at org.apache.hyracks.api.rewriter.runtime.SuperActivityOperatorNodePushable.lambda$runInParallel$0(SuperActivityOperatorNodePushable.java:228) ~[hyracks-api.jar:6.6.0-0000]
      		at java.util.concurrent.FutureTask.run(Unknown Source) [?:?]
      		at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:?]
      		at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:?]
      		at java.lang.Thread.run(Unknown Source) [?:?]
      Caused by: java.lang.IllegalStateException: Unrecognized path structure: storage/partition_0/Default/0/.metadata
      	at org.apache.asterix.common.storage.ResourceReference.parse(ResourceReference.java:93) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.asterix.common.storage.ResourceReference.of(ResourceReference.java:48) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.asterix.common.storage.ResourceReference.ofIndex(ResourceReference.java:43) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.asterix.common.context.DatasetLifecycleManager.getDatasetLastValidComponentId(DatasetLifecycleManager.java:619) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.asterix.common.context.DatasetLifecycleManager.populateOpTrackerAndIdGenerator(DatasetLifecycleManager.java:358) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.asterix.common.context.DatasetLifecycleManager.getOperationTracker(DatasetLifecycleManager.java:335) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.asterix.transaction.management.opcallbacks.PrimaryIndexOperationTrackerFactory.getOperationTracker(PrimaryIndexOperationTrackerFactory.java:52) ~[asterix-transactions.jar:6.6.0-0000]
      	at org.apache.hyracks.storage.am.lsm.btree.dataflow.LSMBTreeLocalResource.createInstance(LSMBTreeLocalResource.java:108) ~[hyracks-storage-am-lsm-btree.jar:6.6.0-0000]
      	at org.apache.hyracks.storage.am.lsm.btree.dataflow.LSMBTreeLocalResource.createInstance(LSMBTreeLocalResource.java:50) ~[hyracks-storage-am-lsm-btree.jar:6.6.0-0000]
      	at org.apache.asterix.common.dataflow.DatasetLocalResource.createInstance(DatasetLocalResource.java:73) ~[asterix-common.jar:6.6.0-0000]
      	at org.apache.hyracks.storage.am.common.build.IndexBuilder.build(IndexBuilder.java:106) ~[hyracks-storage-am-common.jar:6.6.0-0000]
      	at org.apache.hyracks.storage.am.common.dataflow.IndexCreateOperatorNodePushable.initialize(IndexCreateOperatorNodePushable.java:52) ~[hyracks-storage-am-common.jar:6.6.0-0000]
      	at org.apache.hyracks.api.rewriter.runtime.SuperActivityOperatorNodePushable.lambda$runInParallel$0(SuperActivityOperatorNodePushable.java:228) ~[hyracks-api.jar:6.6.0-0000]
      	at java.util.concurrent.FutureTask.run(Unknown Source) [?:?]
      	... 3 more
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          till Till Westmann created issue -
          till Till Westmann made changes -
          Field Original Value New Value
          Fix Version/s 6.6.2 [ 17103 ]
          Fix Version/s 6.6.1 [ 17002 ]
          till Till Westmann made changes -
          Labels triaged
          till Till Westmann made changes -
          Assignee Till Westmann [ till ] Dmitry Lychagin [ dmitry.lychagin ]
          dmitry.lychagin Dmitry Lychagin made changes -
          Rank Ranked higher
          dmitry.lychagin Dmitry Lychagin made changes -
          Sprint CX Sprint 221 [ 1271 ]
          dmitry.lychagin Dmitry Lychagin made changes -
          Rank Ranked lower
          till Till Westmann made changes -
          Link This issue blocks MB-40528 [ MB-40528 ]
          till Till Westmann made changes -
          Labels triaged approved-for-6.6.1 triaged
          dmitry.lychagin Dmitry Lychagin made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          till Till Westmann made changes -
          Sprint CX Sprint 221 [ 1271 ] CX Sprint 221, CX Sprint 222 [ 1271, 1288 ]
          till Till Westmann made changes -
          Rank Ranked higher
          dmitry.lychagin Dmitry Lychagin made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          build-team Couchbase Build Team added a comment -

          Build couchbase-server-6.6.1-9136 contains cbas-core commit 066cdc5 with commit message:
          MB-41968: Internal error when creating a dataset without a name

          umang.agrawal Umang added a comment -

          Following error is raised while creating dataset without name - 

           

          [
            {
              "code": 24112,
              "msg": "Invalid name for a database object: \"<empty>\" (in line 1, at column 1)",
              "query_from_user": "CREATE DATASET `Default`.`` ON `beer-sample` AT `Default`.`l1` WHERE `type`=\"beer\";"
            }
          ]
          

          Verified with couchbase server build 6.6.1-9143

          umang.agrawal Umang made changes -
          Assignee Dmitry Lychagin [ dmitry.lychagin ] Umang [ JIRAUSER24787 ]
          Status Resolved [ 5 ] Closed [ 6 ]
          build-team Couchbase Build Team added a comment -

          Build couchbase-server-7.0.0-3604 contains cbas-core commit 066cdc5 with commit message:
          MB-41968: Internal error when creating a dataset without a name

          build-team Couchbase Build Team added a comment -

          Build couchbase-server-6.6.2-9599 contains cbas-core commit 066cdc5 with commit message:
          MB-41968: Internal error when creating a dataset without a name


            People

            Assignee:
            umang.agrawal Umang
            Reporter:
            till Till Westmann
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty