Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-42095

[CX] LinkServlet returns error code as CBASxxx instead of 24xxx format

    XMLWordPrintable

Details

    • Untriaged
    • 1
    • Unknown
    • CX Sprint 221, CX Sprint 222, CX Sprint 223

    Description

      Currently, any failure on the LinkServlet is returned with a message with the code such as CBASxxx, this needs to be changed to the 24xxx form.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            Hussain.Towaileb Hussain Towaileb created issue -
            till Till Westmann made changes -
            Field Original Value New Value
            Labels triaged
            Hussain.Towaileb Hussain Towaileb made changes -
            Sprint CX Sprint 221 [ 1271 ]
            Hussain.Towaileb Hussain Towaileb made changes -
            Rank Ranked higher
            Hussain.Towaileb Hussain Towaileb made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            Hussain.Towaileb Hussain Towaileb made changes -
            Rank Ranked higher
            Hussain.Towaileb Hussain Towaileb made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            Hussain.Towaileb Hussain Towaileb made changes -
            Rank Ranked higher
            till Till Westmann made changes -
            Sprint CX Sprint 221 [ 1271 ] CX Sprint 221, CX Sprint 222 [ 1271, 1288 ]
            Hussain.Towaileb Hussain Towaileb made changes -
            Rank Ranked higher
            Hussain.Towaileb Hussain Towaileb made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            till Till Westmann made changes -
            Sprint CX Sprint 221, CX Sprint 222 [ 1271, 1288 ] CX Sprint 221, CX Sprint 222, CX Sprint 223 [ 1271, 1288, 1291 ]
            till Till Westmann made changes -
            Link This issue blocks MB-40528 [ MB-40528 ]
            till Till Westmann made changes -
            Labels triaged approved-for-6.6.1 triaged
            till Till Westmann made changes -
            Fix Version/s 6.6.1 [ 17002 ]
            Fix Version/s Cheshire-Cat [ 15915 ]
            Hussain.Towaileb Hussain Towaileb made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]

            Build couchbase-server-6.6.1-9160 contains cbas-core commit 4cfc02c with commit message:
            MB-42095: Use mapped error codes when returning errors from LinkServlet

            build-team Couchbase Build Team added a comment - Build couchbase-server-6.6.1-9160 contains cbas-core commit 4cfc02c with commit message: MB-42095 : Use mapped error codes when returning errors from LinkServlet
            umang.agrawal Umang made changes -
            Labels approved-for-6.6.1 triaged approved-for-6.6.1 needs-info triaged
            umang.agrawal Umang added a comment -

            Verified with build 6.6.1-9164

            Old error message -

            Error creating link: CBAS0056: Invalid credentials for link Default.q1
            

            New error message -

            Error creating link: 20002:Invalid credentials for link Default.q2
            

            umang.agrawal Umang added a comment - Verified with build 6.6.1-9164 Old error message - Error creating link: CBAS0056: Invalid credentials for link Default.q1 New error message - Error creating link: 20002 :Invalid credentials for link Default.q2
            umang.agrawal Umang made changes -
            VERIFICATION STEPS Create remote link using wrong credentials.
            Assignee Hussain Towaileb [ hussain.towaileb ] Umang [ JIRAUSER24787 ]
            Status Resolved [ 5 ] Closed [ 6 ]
            till Till Westmann made changes -
            Link This issue is duplicated by MB-42464 [ MB-42464 ]
            till Till Westmann made changes -
            Labels approved-for-6.6.1 needs-info triaged approved-for-6.6.1 request-dev-verify triaged
            till Till Westmann made changes -
            Labels approved-for-6.6.1 request-dev-verify triaged approved-for-6.6.1 triaged

            Removed request-dev-verify as the issue is closed as a duplicate.

            till Till Westmann added a comment - Removed request-dev-verify as the issue is closed as a duplicate.

            Build couchbase-server-7.0.0-3636 contains cbas-core commit 4cfc02c with commit message:
            MB-42095: Use mapped error codes when returning errors from LinkServlet

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.0-3636 contains cbas-core commit 4cfc02c with commit message: MB-42095 : Use mapped error codes when returning errors from LinkServlet

            Build couchbase-server-6.6.2-9599 contains cbas-core commit 4cfc02c with commit message:
            MB-42095: Use mapped error codes when returning errors from LinkServlet

            build-team Couchbase Build Team added a comment - Build couchbase-server-6.6.2-9599 contains cbas-core commit 4cfc02c with commit message: MB-42095 : Use mapped error codes when returning errors from LinkServlet

            People

              umang.agrawal Umang
              Hussain.Towaileb Hussain Towaileb
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty