Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-4295

Upgrade from 1.6.5.4 ->1.7.0 -> 1.7.1.1 is not supported

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.7.1.1, 1.7.2
    • Fix Version/s: 1.7.2
    • Component/s: installer
    • Security Level: Public
    • Flagged:
      Release Note

      Description

      ERROR MESSAGES:-
      [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - Would overwrite the following files:
      [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default
      [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-0.mb
      [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-3.mb
      [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-2.mb
      [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-1.mb
      [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - ERROR: upgrade failed for bucket: default
      [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - dpkg: error processing membase-server (--install):
      [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - subprocess installed post-installation script returned error exit status 1
      [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - Errors were encountered while processing:
      [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - ERROR - membase-server
      [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - (Reading database ... 53283 files and directories currently installed.)

      [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - /opt/membase/bin/mbdbupgrade /var/opt/membase/1.6.5.4/data/ns_1/default /var/opt/membase/1.6.5.4/data/ns_1/default-data
      [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade pid: 22871
      [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade err: 256
      [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - Processing triggers for ureadahead ...

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        karan Karan Kumar (Inactive) created issue -
        karan Karan Kumar (Inactive) made changes -
        Field Original Value New Value
        Summary Upgrade from 1.7.0 to 1.7.2r-9 results mbdbupgrade err: 256 on Ubuntu 32 and 64 bit. Upgrade from 1.6.5.4 to 1.7.1.1 to 1.7.2r-9 results in mbdbupgrade err: 256 on Ubuntu 32 and 64 bit.
        Affects Version/s 1.7.1.1 [ 10210 ]
        Description dpkg -i membase-server-enterprise_x86_1.7.2r-9-gd41b35f.deb
        (Reading database ... 49324 files and directories currently installed.)
        Preparing to replace membase-server 1.7.0 (using membase-server-enterprise_x86_1.7.2r-9-gd41b35f.deb) ...
         * Stopped Membase server
        Upgrading previous membase ... (1.7.0)
        Stopping previous membase ... (1.7.0)
         * Stopped Membase server
        Saving previous membase config.dat ...
        Cleaning symlinks ...
        Unpacking replacement membase-server ...
        Setting up membase-server (1.7.2r) ...
        Upgrading from 1.7.0, directory /opt/membase/var/lib/membase/config ...
          /opt/membase/bin/mbupgrade -c /opt/membase/var/lib/membase/config -a yes
        Automatic mode: running without interactive questions or confirmations.
        Upgrading your Membase Server to 1.7.2r-9-gd41b35f.
        The upgrade process might take awhile.
        Analysing...
        Previous config.dat file is /opt/membase/var/lib/membase/config/config.dat.debsave
        Target node: ns_1@10.1.5.96

        Membase should not be running.
          Please use: /etc/init.d/membase-server stop

        Database dir: /var/opt/membase/1.6.5.4/data/ns_1

        Buckets to upgrade: default

        Checking disk space available for buckets in directory:
          /var/opt/membase/1.6.5.4/data/ns_1
          Free disk bucket space wanted: 39651328.0
          Free disk bucket space available: 11945668608
          Free disk space factor: 2.0
          Ok.

        Analysis complete.

        Copying /opt/membase/var/lib/membase/config/config.dat.debsave
            cp /opt/membase/var/lib/membase/config/config.dat.debsave /opt/membase/var/lib/membase/config/config.dat
        Copying /opt/membase/var/lib/membase/ip.debsave
            cp /opt/membase/var/lib/membase/ip.debsave /opt/membase/var/lib/membase/ip
        Ensuring bucket data directories.
        Ensuring bucket data directory: /var/opt/membase/1.6.5.4/data/ns_1/default-data
            mkdir -p /var/opt/membase/1.6.5.4/data/ns_1/default-data
        Ensuring dbdir owner/group: /var/opt/membase/1.6.5.4/data/ns_1
            chown -R membase:membase /var/opt/membase/1.6.5.4/data/ns_1
        Upgrading buckets.
        Upgrading bucket: default
            /opt/membase/bin/mbdbupgrade /var/opt/membase/1.6.5.4/data/ns_1/default /var/opt/membase/1.6.5.4/data/ns_1/default-data
        mbdbupgrade pid: 30036
        Would overwrite the following files:
        /var/opt/membase/1.6.5.4/data/ns_1/default-data/default
        /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-2.mb
        /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-0.mb
        /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-1.mb
        /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-3.mb
        mbdbupgrade err: 256
        ERROR: upgrade failed for bucket: default
        dpkg: error processing membase-server (--install):
         subprocess installed post-installation script returned error exit status 1
        Errors were encountered while processing:
         membase-server

        [2011-09-20 10:17:16,806] - [remote_util] [47550853327296] - INFO - running command dpkg -i /tmp/membase-server-enterprise_x86_64_1.7.2r-8-g928c8b1.deb
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - INFO - command executed successfully
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - Would overwrite the following files:
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-0.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-3.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-2.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-1.mb
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - ERROR: upgrade failed for bucket: default
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - dpkg: error processing membase-server (--install):
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - subprocess installed post-installation script returned error exit status 1
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - Errors were encountered while processing:
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - ERROR - membase-server
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - (Reading database ... 53283 files and directories currently installed.)
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - Preparing to replace membase-server 1.7.1.1 (using .../membase-server-enterprise_x86_64_1.7.2r-8-g928c8b1.deb) ...
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - * Stopped membase-server
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - Upgrading previous membase ... (1.7.1.1)
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - Stopping previous membase ... (1.7.1.1)
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - * Stopped membase-server
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - Saving previous membase config.dat ...
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - Cleaning symlinks ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - Unpacking replacement membase-server ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - Setting up membase-server (1.7.2r) ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - Upgrading from 1.7.1.1, directory /opt/membase/var/lib/membase/config ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - /opt/membase/bin/mbupgrade -c /opt/membase/var/lib/membase/config -a yes
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - Automatic mode: running without interactive questions or confirmations.
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - Upgrading your Membase Server to 1.7.2r-8-g928c8b1.
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - The upgrade process might take awhile.
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - Analysing...
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO - Previous config.dat file is /opt/membase/var/lib/membase/config/config.dat.debsave
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO - Target node: ns_1@10.1.4.82
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO - Membase should not be running.
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO - Please use: /etc/init.d/membase-server stop
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO - Database dir: /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO - Buckets to upgrade: default
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO - Checking disk space available for buckets in directory:
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO - /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO - Free disk bucket space wanted: 35848192.0
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO - Free disk bucket space available: 11647188992
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO - Free disk space factor: 2.0
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO - Ok.
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - Analysis complete.
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - Copying /opt/membase/var/lib/membase/config/config.dat.debsave
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - cp /opt/membase/var/lib/membase/config/config.dat.debsave /opt/membase/var/lib/membase/config/config.dat
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - Copying /opt/membase/var/lib/membase/ip.debsave
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - cp /opt/membase/var/lib/membase/ip.debsave /opt/membase/var/lib/membase/ip
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - Ensuring bucket data directories.
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - Ensuring bucket data directory: /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - mkdir -p /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - Ensuring dbdir owner/group: /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - chown -R membase:membase /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - Upgrading buckets.
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - Upgrading bucket: default
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - /opt/membase/bin/mbdbupgrade /var/opt/membase/1.6.5.4/data/ns_1/default /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade pid: 22871
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade err: 256
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - Processing triggers for ureadahead ...
        karan Karan Kumar (Inactive) made changes -
        Summary Upgrade from 1.6.5.4 to 1.7.1.1 to 1.7.2r-9 results in mbdbupgrade err: 256 on Ubuntu 32 and 64 bit. Upgrade from 1.6.5.4 ->1.7.1.1 -> 1.7.2r-9 upgrade fails on Ubuntu 32 and 64 bit.
        karan Karan Kumar (Inactive) made changes -
        Assignee Steve Yen [ steve ]
        farshid Farshid Ghods (Inactive) made changes -
        Assignee Steve Yen [ steve ] Bin Cui [ bcui ]
        bcui Bin Cui made changes -
        Assignee Bin Cui [ bcui ] Steve Yen [ steve ]
        steve Steve Yen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.7.2 [ 10203 ]
        Resolution Fixed [ 1 ]
        karan Karan Kumar (Inactive) made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        steve Steve Yen made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        karan Karan Kumar (Inactive) made changes -
        Summary Upgrade from 1.6.5.4 ->1.7.1.1 -> 1.7.2r-9 upgrade fails on Ubuntu 32 and 64 bit. Upgrade from 1.6.5.4 ->1.7.0 -> 1.7.1.1 is not supported
        Labels 1.7.1-release-notes
        Description
        [2011-09-20 10:17:16,806] - [remote_util] [47550853327296] - INFO - running command dpkg -i /tmp/membase-server-enterprise_x86_64_1.7.2r-8-g928c8b1.deb
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - INFO - command executed successfully
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - Would overwrite the following files:
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-0.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-3.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-2.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-1.mb
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - ERROR: upgrade failed for bucket: default
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - dpkg: error processing membase-server (--install):
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - subprocess installed post-installation script returned error exit status 1
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - Errors were encountered while processing:
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - ERROR - membase-server
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - (Reading database ... 53283 files and directories currently installed.)
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - Preparing to replace membase-server 1.7.1.1 (using .../membase-server-enterprise_x86_64_1.7.2r-8-g928c8b1.deb) ...
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - * Stopped membase-server
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - Upgrading previous membase ... (1.7.1.1)
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - Stopping previous membase ... (1.7.1.1)
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - * Stopped membase-server
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - Saving previous membase config.dat ...
        [2011-09-20 10:17:49,027] - [remote_util] [47550853327296] - INFO - Cleaning symlinks ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - Unpacking replacement membase-server ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - Setting up membase-server (1.7.2r) ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - Upgrading from 1.7.1.1, directory /opt/membase/var/lib/membase/config ...
        [2011-09-20 10:17:49,028] - [remote_util] [47550853327296] - INFO - /opt/membase/bin/mbupgrade -c /opt/membase/var/lib/membase/config -a yes
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - Automatic mode: running without interactive questions or confirmations.
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - Upgrading your Membase Server to 1.7.2r-8-g928c8b1.
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - The upgrade process might take awhile.
        [2011-09-20 10:17:49,029] - [remote_util] [47550853327296] - INFO - Analysing...
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO - Previous config.dat file is /opt/membase/var/lib/membase/config/config.dat.debsave
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO - Target node: ns_1@10.1.4.82
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,030] - [remote_util] [47550853327296] - INFO - Membase should not be running.
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO - Please use: /etc/init.d/membase-server stop
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO - Database dir: /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,031] - [remote_util] [47550853327296] - INFO - Buckets to upgrade: default
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO - Checking disk space available for buckets in directory:
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO - /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,032] - [remote_util] [47550853327296] - INFO - Free disk bucket space wanted: 35848192.0
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO - Free disk bucket space available: 11647188992
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO - Free disk space factor: 2.0
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO - Ok.
        [2011-09-20 10:17:49,033] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - Analysis complete.
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO -
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - Copying /opt/membase/var/lib/membase/config/config.dat.debsave
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - cp /opt/membase/var/lib/membase/config/config.dat.debsave /opt/membase/var/lib/membase/config/config.dat
        [2011-09-20 10:17:49,034] - [remote_util] [47550853327296] - INFO - Copying /opt/membase/var/lib/membase/ip.debsave
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - cp /opt/membase/var/lib/membase/ip.debsave /opt/membase/var/lib/membase/ip
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - Ensuring bucket data directories.
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - Ensuring bucket data directory: /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,035] - [remote_util] [47550853327296] - INFO - mkdir -p /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - Ensuring dbdir owner/group: /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - chown -R membase:membase /var/opt/membase/1.6.5.4/data/ns_1
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - Upgrading buckets.
        [2011-09-20 10:17:49,036] - [remote_util] [47550853327296] - INFO - Upgrading bucket: default
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - /opt/membase/bin/mbdbupgrade /var/opt/membase/1.6.5.4/data/ns_1/default /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade pid: 22871
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade err: 256
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - Processing triggers for ureadahead ...
        ERROR MESSAGES:-
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - Would overwrite the following files:
        [2011-09-20 10:17:49,023] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-0.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-3.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-2.mb
        [2011-09-20 10:17:49,024] - [remote_util] [47550853327296] - ERROR - /var/opt/membase/1.6.5.4/data/ns_1/default-data/default-1.mb
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - ERROR: upgrade failed for bucket: default
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - dpkg: error processing membase-server (--install):
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - subprocess installed post-installation script returned error exit status 1
        [2011-09-20 10:17:49,025] - [remote_util] [47550853327296] - ERROR - Errors were encountered while processing:
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - ERROR - membase-server
        [2011-09-20 10:17:49,026] - [remote_util] [47550853327296] - INFO - (Reading database ... 53283 files and directories currently installed.)

        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - /opt/membase/bin/mbdbupgrade /var/opt/membase/1.6.5.4/data/ns_1/default /var/opt/membase/1.6.5.4/data/ns_1/default-data
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade pid: 22871
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - mbdbupgrade err: 256
        [2011-09-20 10:17:49,037] - [remote_util] [47550853327296] - INFO - Processing triggers for ureadahead ...
        Flagged [Release Note]
        karan Karan Kumar (Inactive) made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Assignee Steve Yen [ steve ] Karan Kumar [ karan ]
        farshid Farshid Ghods (Inactive) made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        farshid Farshid Ghods (Inactive) made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        farshid Farshid Ghods (Inactive) made changes -
        Comment [ Integrated in single-node-windows-64-install #301 (See [http://qa.hq.northscale.net/job/single-node-windows-64-install/301/])
            Disable upgradetest for # Bug MB-4295

        karan :
        Files :
        * conf/upgrade-tests.conf
        ]
        karan Karan Kumar (Inactive) made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        peter peter made changes -
        Component/s installer [ 10221 ]
        Component/s linux_installer [ 10021 ]

          People

          • Assignee:
            karan Karan Kumar (Inactive)
            Reporter:
            karan Karan Kumar (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes