Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-43192

[Object Store] cbbackupmgr info fails due to new 'cloud_type' field

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • Cheshire-Cat
    • 7.0.0
    • tools
    • None
    • Untriaged
    • 1
    • No

    Description

      What's the issue?
      In MB-42354 we added a cloud provide field to the archive version file, when performing an info at the archive level all files will be downloaded using a download pool. This means we won't update the provider type in the version file causing the info to error out because the staging directory is invalid.

      Error getting archive information: existing staging directory is for another cloud provider, retry with another one or recreate the existing one
      

      I haven't tested but I believe this will be an issue for collect-logs as well. Can confirm, is affected.

      Note that this only happens after the first successful population of the staging directory, therefore, a temporary workaround until I've fixed the issue is to recreate the staging directory and re-run the sub-command.

      What's the fix?
      The '.backup' and '.info' files have special significance for cloud backups and are manually downloaded and excluded from being downloaded by worker pools (in the normal case i.e. when performing an operation at the repo level). However when performing an operation at the archive level they are not; we should detect and handle this scenario by populating the cloud provider field in the version file (along with any other missing fields).

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            Build couchbase-server-7.0.0-3992 contains backup commit ccd58c2 with commit message:
            MB-43192 Avoid overwriting the '.backup' file in 'GetAllRepoMeta'

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.0-3992 contains backup commit ccd58c2 with commit message: MB-43192 Avoid overwriting the '.backup' file in 'GetAllRepoMeta'

            People

              james.lee James Lee
              james.lee James Lee
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty