Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-4453

unable to create a default bucket using membase-cli on 1.7.2 GA build

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.2
    • Fix Version/s: 1.7.3
    • Component/s: None
    • Security Level: Public
    No reviews matched the request. Check your Options in the drop-down menu of this sections header.

      Activity

      Hide
      thuan Thuan Nguyen added a comment - - edited

      I verify this bug is fixed on membase server 1.7.2 on both linux and windows with the new buckets.py and membase.exe files from the build 1.7.3r-4.
      Steps to do

      • Stop membase server 1.7.2
      • Delete file buckets.py at /opt/membase/lib/python (on unix) or membase.exe at c:\Program Files\Membase\Server\bin (on windows)
      • Copy new fixed file buckets.py (on unix) or membase.exe (on windows) to correct location.
      • Restart membase server 1.7.2
      • Run cli commands to create bucket. Membase buckets created.
      Show
      thuan Thuan Nguyen added a comment - - edited I verify this bug is fixed on membase server 1.7.2 on both linux and windows with the new buckets.py and membase.exe files from the build 1.7.3r-4. Steps to do Stop membase server 1.7.2 Delete file buckets.py at /opt/membase/lib/python (on unix) or membase.exe at c:\Program Files\Membase\Server\bin (on windows) Copy new fixed file buckets.py (on unix) or membase.exe (on windows) to correct location. Restart membase server 1.7.2 Run cli commands to create bucket. Membase buckets created.
      Show
      farshid Farshid Ghods (Inactive) added a comment - https://github.com/membase/membase-cli/commit/653e48df02ff9b9c36724850c014f1a2f6b3e19d
      Hide
      farshid Farshid Ghods (Inactive) added a comment -

      With the recent upgrade to 1.7.2, I can no longer create the default bucket from the CLI.

      All of these fail:
      [root@ip-10-80-187-47 ~]# /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-port=11211 --bucket-type=membase --bucket-replica=1
      ERROR: unable to bucket-create (400) Bad Request
      {u'errors':

      {u'proxyPort': u'port is already in use', u'replicaNumber': u'Warning, you do not have enough servers to support this number of replicas.'}

      , u'summaries': {u'ramSummary':

      {u'thisUsed': 0, u'thisAlloc': 1048576000, u'otherBuckets': 0, u'nodesCount': 1, u'free': 5938085888.0, u'perNodeMegs': 1000, u'total': 6986661888.0}

      , u'hddSummary':

      {u'thisUsed': 0, u'total':10568916992.0, u'otherBuckets': 0, u'free': 7715309405.0, u'otherData': 2853607587.0}

      }}
      ERROR: port is already in use
      ERROR: Warning, you do not have enough servers to support this number of replicas.
      ERROR: command: bucket-create: localhost:8091, 2

      [root@ip-10-80-187-47 ~]# /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-port=11211 --bucket-type=membase --bucket-replica=0
      ERROR: unable to bucket-create (400) Bad Request
      {u'errors':

      {u'proxyPort': u'port is already in use'}

      , u'summaries': {u'ramSummary':

      {u'thisUsed': 0, u'thisAlloc': 1048576000, u'otherBuckets': 0, u'nodesCount': 1, u'free': 5938085888.0, u'perNodeMegs': 1000, u'total': 6986661888.0}

      , u'hddSummary':

      {u'thisUsed': 0, u'total': 10568916992.0, u'otherBuckets': 0, u'free': 7715309405.0, u'otherData': 2853607587.0}

      }}
      ERROR: port is already in use
      ERROR: command: bucket-create: localhost:8091, 2

      [root@ip-10-80-187-47 ~]# /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-port=11212 --bucket-type=membase --bucket-replica=1
      ERROR: default bucket must be on port 11211.
      ERROR: command: bucket-create: localhost:8091, 2

      [root@ip-10-80-187-47 ~]# /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-type=membase --bucket-replica=1
      ERROR: unable to bucket-create (400) Bad Request
      {u'errors':

      {u'authType': u'invalid authType'}

      , u'summaries': {u'ramSummary':

      {u'thisUsed': 0, u'thisAlloc': 0, u'otherBuckets': 0, u'nodesCount': 1, u'free': 6986661888.0, u'perNodeMegs': 0, u'total': 6986661888.0}

      , u'hddSummary':

      {u'thisUsed': 0, u'total': 10568916992.0, u'otherBuckets': 0, u'free': 7715309405.0, u'otherData': 2853607587.0}

      }}
      ERROR: invalid authType
      ERROR: command: bucket-create: localhost:8091, 2
      [root@ip-10-80-187-47 ~]#

      Show
      farshid Farshid Ghods (Inactive) added a comment - With the recent upgrade to 1.7.2, I can no longer create the default bucket from the CLI. All of these fail: [root@ip-10-80-187-47 ~] # /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-port=11211 --bucket-type=membase --bucket-replica=1 ERROR: unable to bucket-create (400) Bad Request {u'errors': {u'proxyPort': u'port is already in use', u'replicaNumber': u'Warning, you do not have enough servers to support this number of replicas.'} , u'summaries': {u'ramSummary': {u'thisUsed': 0, u'thisAlloc': 1048576000, u'otherBuckets': 0, u'nodesCount': 1, u'free': 5938085888.0, u'perNodeMegs': 1000, u'total': 6986661888.0} , u'hddSummary': {u'thisUsed': 0, u'total':10568916992.0, u'otherBuckets': 0, u'free': 7715309405.0, u'otherData': 2853607587.0} }} ERROR: port is already in use ERROR: Warning, you do not have enough servers to support this number of replicas. ERROR: command: bucket-create: localhost:8091, 2 [root@ip-10-80-187-47 ~] # /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-port=11211 --bucket-type=membase --bucket-replica=0 ERROR: unable to bucket-create (400) Bad Request {u'errors': {u'proxyPort': u'port is already in use'} , u'summaries': {u'ramSummary': {u'thisUsed': 0, u'thisAlloc': 1048576000, u'otherBuckets': 0, u'nodesCount': 1, u'free': 5938085888.0, u'perNodeMegs': 1000, u'total': 6986661888.0} , u'hddSummary': {u'thisUsed': 0, u'total': 10568916992.0, u'otherBuckets': 0, u'free': 7715309405.0, u'otherData': 2853607587.0} }} ERROR: port is already in use ERROR: command: bucket-create: localhost:8091, 2 [root@ip-10-80-187-47 ~] # /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-port=11212 --bucket-type=membase --bucket-replica=1 ERROR: default bucket must be on port 11211. ERROR: command: bucket-create: localhost:8091, 2 [root@ip-10-80-187-47 ~] # /opt/membase/bin/membase bucket-create -c localhost:8091 -u Administrator -p password --bucket=default --bucket-ramsize=1000 --bucket-type=membase --bucket-replica=1 ERROR: unable to bucket-create (400) Bad Request {u'errors': {u'authType': u'invalid authType'} , u'summaries': {u'ramSummary': {u'thisUsed': 0, u'thisAlloc': 0, u'otherBuckets': 0, u'nodesCount': 1, u'free': 6986661888.0, u'perNodeMegs': 0, u'total': 6986661888.0} , u'hddSummary': {u'thisUsed': 0, u'total': 10568916992.0, u'otherBuckets': 0, u'free': 7715309405.0, u'otherData': 2853607587.0} }} ERROR: invalid authType ERROR: command: bucket-create: localhost:8091, 2 [root@ip-10-80-187-47 ~] #

        People

        • Assignee:
          frank Frank Weigel (Inactive)
          Reporter:
          farshid Farshid Ghods (Inactive)
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Gerrit Reviews

            There are no open Gerrit changes