Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-4497

couchbase server 1.8.0 failed to install on ubuntu 9.10 64bit

    Details

      Description

      Install couchbase server 1.8.0r-12 on ubuntu 9.10 64bit.
      The installation failed
      root@ubuntu:/tmp# dpkg -i couchbase-server_x86_64-1.8.0r-12-gf3f32b3.deb
      Selecting previously deselected package couchbase-server.
      (Reading database ... 54083 files and directories currently installed.)
      Unpacking couchbase-server (from couchbase-server_x86_64-1.8.0r-12-gf3f32b3.deb) ...
      dpkg: dependency problems prevent configuration of couchbase-server:
      couchbase-server depends on libc6 (>= 2.11); however:
      Version of libc6 on system is 2.10.1-0ubuntu16.
      couchbase-server depends on libssl0.9.8 (>= 0.9.8k-1); however:
      Version of libssl0.9.8 on system is 0.9.8g-16ubuntu3.
      dpkg: error processing couchbase-server (--install):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      couchbase-server

      the IP of this server is 10.1.2.27

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        alkondratenko Aleksey Kondratenko (Inactive) added a comment -

        note that 9.10 is long unsupported. So we should stop doing anything on this release.

        However, according to this http://en.wikipedia.org/wiki/Ubuntu_(operating_system) 8.04 LTS is still supported. So if we care, we should build our software on 8.04 LTS so that it's installable there.

        Show
        alkondratenko Aleksey Kondratenko (Inactive) added a comment - note that 9.10 is long unsupported . So we should stop doing anything on this release. However, according to this http://en.wikipedia.org/wiki/Ubuntu_(operating_system ) 8.04 LTS is still supported. So if we care, we should build our software on 8.04 LTS so that it's installable there.
        Hide
        steve Steve Yen added a comment -

        Although Ubuntu supports 8.04 LTS still, we haven't; so we should not start supporting it suddenly in 1.8.0.

        Show
        steve Steve Yen added a comment - Although Ubuntu supports 8.04 LTS still, we haven't; so we should not start supporting it suddenly in 1.8.0.
        Hide
        dipti Dipti Borkar added a comment -

        Please provide pre-requisites needed to install 1.8.0. These steps need to be provided to MC to be documented as pre-reqs.

        Show
        dipti Dipti Borkar added a comment - Please provide pre-requisites needed to install 1.8.0. These steps need to be provided to MC to be documented as pre-reqs.
        Hide
        steve Steve Yen added a comment -

        Farshid,
        Need some new ubuntu 9.10 buildslaves chef'ed up.

        ---------------

        > SO we have concluded that there is no way to build on 10.04 and get the binary to work on 9.10 even with pre-requisites ?

        There is some way, likely. But it's way too complex.

        BTW, for building packages of gpicker I'm using chrooted installation of very old Debian. So my packages work on all more or less recent ubuntus and debians. I don't know if our buildbot herding folks are prepared for such tricks, but it was an easy way for me.

        > > the implication is folks will have to install some pre-requisites if they want to run on the very latest ubuntu.

        > When you say very latest, which specific versions do you mean? 10.04 or new ones that we won't support officially for 1.8.* ?

        Debian testing started using openssl 1.0 around August, so I suspected that latest ubuntu release (11.10) is using it too. And I am right:

        http://packages.ubuntu.com/search?keywords=libssl&searchon=names&suite=oneiric&section=all

        while 11.04 (one version back) is using 0.9.8:

        http://packages.ubuntu.com/search?keywords=libssl&searchon=names&suite=natty&section=all

        So our packages built on older release will work without any extra compat packages up to 11.04, but will require compat openssl on latest ubuntu release which is 11.10. That's very similar situation that we have on our RHEL5 packages that do not work out of the box on RHEL6 without compat version of openssl.

        All that happens because openssl transition from 0.9.8 to 1.0 also did change of API (and ABI). It's possible to install both versions because they have different suffix after .so, but distros by default install only newer one.

        Best fix is to build two sets of packages both for .deb and for .rpm. One for older openssl (RHEL5 and Ubuntu up to 11.04) and one for later openssl (RHEL6, latest Fedora's, Amazon Linux and Ubuntu 11.10 and later).

        Show
        steve Steve Yen added a comment - Farshid, Need some new ubuntu 9.10 buildslaves chef'ed up. --------------- > SO we have concluded that there is no way to build on 10.04 and get the binary to work on 9.10 even with pre-requisites ? There is some way, likely. But it's way too complex. BTW, for building packages of gpicker I'm using chrooted installation of very old Debian. So my packages work on all more or less recent ubuntus and debians. I don't know if our buildbot herding folks are prepared for such tricks, but it was an easy way for me. > > the implication is folks will have to install some pre-requisites if they want to run on the very latest ubuntu. > When you say very latest, which specific versions do you mean? 10.04 or new ones that we won't support officially for 1.8.* ? Debian testing started using openssl 1.0 around August, so I suspected that latest ubuntu release (11.10) is using it too. And I am right: http://packages.ubuntu.com/search?keywords=libssl&searchon=names&suite=oneiric&section=all while 11.04 (one version back) is using 0.9.8: http://packages.ubuntu.com/search?keywords=libssl&searchon=names&suite=natty&section=all So our packages built on older release will work without any extra compat packages up to 11.04, but will require compat openssl on latest ubuntu release which is 11.10. That's very similar situation that we have on our RHEL5 packages that do not work out of the box on RHEL6 without compat version of openssl. All that happens because openssl transition from 0.9.8 to 1.0 also did change of API (and ABI). It's possible to install both versions because they have different suffix after .so, but distros by default install only newer one. Best fix is to build two sets of packages both for .deb and for .rpm. One for older openssl (RHEL5 and Ubuntu up to 11.04) and one for later openssl (RHEL6, latest Fedora's, Amazon Linux and Ubuntu 11.10 and later).
        Hide
        steve Steve Yen added a comment -

        9.10 was no longer officially supported platform for 1.8.0? If so, can close/resolve this bug?

        Show
        steve Steve Yen added a comment - 9.10 was no longer officially supported platform for 1.8.0? If so, can close/resolve this bug?
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        couchbase server 1.8 installation works fine out of the box on ubuntu 10.04 because server does not depend on openssl anymore

        Show
        farshid Farshid Ghods (Inactive) added a comment - couchbase server 1.8 installation works fine out of the box on ubuntu 10.04 because server does not depend on openssl anymore
        Hide
        dipti Dipti Borkar added a comment -

        Farshid, does 2.0 dp3 / dp4 work fine out of the box as well on ubuntu 10.04 ?

        Show
        dipti Dipti Borkar added a comment - Farshid, does 2.0 dp3 / dp4 work fine out of the box as well on ubuntu 10.04 ?

          People

          • Assignee:
            farshid Farshid Ghods (Inactive)
            Reporter:
            thuan Thuan Nguyen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes