Need some new ubuntu 9.10 buildslaves chef'ed up.
> SO we have concluded that there is no way to build on 10.04 and get the binary to work on 9.10 even with pre-requisites ?
There is some way, likely. But it's way too complex.
BTW, for building packages of gpicker I'm using chrooted installation of very old Debian. So my packages work on all more or less recent ubuntus and debians. I don't know if our buildbot herding folks are prepared for such tricks, but it was an easy way for me.
> > the implication is folks will have to install some pre-requisites if they want to run on the very latest ubuntu.
> When you say very latest, which specific versions do you mean? 10.04 or new ones that we won't support officially for 1.8.* ?
Debian testing started using openssl 1.0 around August, so I suspected that latest ubuntu release (11.10) is using it too. And I am right:
while 11.04 (one version back) is using 0.9.8:
So our packages built on older release will work without any extra compat packages up to 11.04, but will require compat openssl on latest ubuntu release which is 11.10. That's very similar situation that we have on our RHEL5 packages that do not work out of the box on RHEL6 without compat version of openssl.
All that happens because openssl transition from 0.9.8 to 1.0 also did change of API (and ABI). It's possible to install both versions because they have different suffix after .so, but distros by default install only newer one.
Best fix is to build two sets of packages both for .deb and for .rpm. One for older openssl (RHEL5 and Ubuntu up to 11.04) and one for later openssl (RHEL6, latest Fedora's, Amazon Linux and Ubuntu 11.10 and later).