Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-46932

Recovered instances do not compact

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • Cheshire-Cat
    • 7.1.0
    • storage-engine
    • Untriaged
    • 1
    • Yes

    Description

      During recovery, swap() of recovered instance seems to not copy storeCtx, causing cfGetter to return gcFilter with wrong gc snapshot number intervals. Any page compact of a recovered instance will cause MVCC versions to pile up.

      Attachments

        Issue Links

          For Gerrit Dashboard: MB-46932
          # Subject Branch Project Status CR V

          Activity

            Build couchbase-server-7.1.0-1082 contains plasma commit 8f8f0fe with commit message:
            MB-46932: Do not pre-allcoate plasma instance for recovery

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.1.0-1082 contains plasma commit 8f8f0fe with commit message: MB-46932 : Do not pre-allcoate plasma instance for recovery

            Build couchbase-server-7.1.0-1124 contains plasma commit a32ce43 with commit message:
            MB-46932: Do not continue on checkpoint recovery after recovery is done

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.1.0-1124 contains plasma commit a32ce43 with commit message: MB-46932 : Do not continue on checkpoint recovery after recovery is done
            jliang John Liang added a comment -

            Akhil Mundroy Can you help to specify the steps to reproduce this issue for QE? Thanks.

            jliang John Liang added a comment - Akhil Mundroy Can you help to specify the steps to reproduce this issue for QE? Thanks.

            Verification Steps:

            1. Create collection, add documents, create and build index.
            2. kill indexer process.
            3. Delete all documents in collection.
            4. Monitor storage stats:
              1. compacts should increase
              2. lss_data_size should decrease
              3. total_records should tend to 0

             

            Without the fix, stats in steps (4.2) and (4.3) may not come down to expected levels due to compacts not clearing out items.

            akhil.mundroy Akhil Mundroy added a comment - Verification Steps: Create collection, add documents, create and build index. kill indexer process. Delete all documents in collection. Monitor storage stats: compacts should increase lss_data_size should decrease total_records should tend to 0   Without the fix, stats in steps (4.2) and (4.3) may not come down to expected levels due to compacts not clearing out items.

            Closing this one as test containing above passed with latest build. 

            sanjit.chauhan Sanjit Chauhan added a comment - Closing this one as test containing above passed with latest build. 

            People

              sanjit.chauhan Sanjit Chauhan
              akhil.mundroy Akhil Mundroy
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty