Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-4724

sample bucket loader does not work if python 2.6 is not installed or is not the default python interpreter

    Details

      Description

      install latest 2.0 build ( 2.0.0r-602 )

      after setting up the node go to the settings and choose "sample bucket" and click on "create"

      btw . things work just fine if you run cluster_run but it fails on rpm/deb installations.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        daleharvey Dale Harvey added a comment -

        looking into it now

        Show
        daleharvey Dale Harvey added a comment - looking into it now
        Hide
        steve Steve Yen added a comment -

        dipti wants to see if getting the loader to run on python 2.4 is easy

        Show
        steve Steve Yen added a comment - dipti wants to see if getting the loader to run on python 2.4 is easy
        Hide
        daleharvey Dale Harvey added a comment -

        It would mean pretty significant changes to the couchbase python client, as that also requires 2.6 (so no)

        Show
        daleharvey Dale Harvey added a comment - It would mean pretty significant changes to the couchbase python client, as that also requires 2.6 (so no)
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        we can add a release note for 2.0 dev preview 4 that sample bucket loader won't work if python 2.6 is not the default python on the box ( applies only to centos 5 users)

        for 2.0 beta however we want to completely fix this issue and remove all python 2.6 dependant scripts from couchbase ( scripts including cbrestore )

        Show
        farshid Farshid Ghods (Inactive) added a comment - we can add a release note for 2.0 dev preview 4 that sample bucket loader won't work if python 2.6 is not the default python on the box ( applies only to centos 5 users) for 2.0 beta however we want to completely fix this issue and remove all python 2.6 dependant scripts from couchbase ( scripts including cbrestore )
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        workaround is to instal python 2.6 and change /usr/bin/python to point to /usr/bin/python2.6

        this works just fine if you use amazon basic AMIs ( which is a mixture of centos 5 and centos 6) but if you make this change on a centos 5 "yum" will not work

        Show
        farshid Farshid Ghods (Inactive) added a comment - workaround is to instal python 2.6 and change /usr/bin/python to point to /usr/bin/python2.6 this works just fine if you use amazon basic AMIs ( which is a mixture of centos 5 and centos 6) but if you make this change on a centos 5 "yum" will not work
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        Dale,

        for dp-4 we are going to have a release note for this issue.

        Show
        farshid Farshid Ghods (Inactive) added a comment - Dale, for dp-4 we are going to have a release note for this issue.
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        will be part of 2.0 dp4 release notes

        Show
        farshid Farshid Ghods (Inactive) added a comment - will be part of 2.0 dp4 release notes
        Hide
        mccouch MC Brown (Inactive) added a comment -

        A note has been added to the 2.0DP4 release notes, with workaround.

        Show
        mccouch MC Brown (Inactive) added a comment - A note has been added to the 2.0DP4 release notes, with workaround.

          People

          • Assignee:
            mccouch MC Brown (Inactive)
            Reporter:
            farshid Farshid Ghods (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes