Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-47769

EE compact time elapsed increased in 7.1

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 7.1.0
    • 7.1.0
    • tools
    • Untriaged
    • 1
    • Yes

    Attachments

      Issue Links

        For Gerrit Dashboard: MB-47769
        # Subject Branch Project Status CR V

        Activity

          bo-chun.wang Bo-Chun Wang created issue -
          bo-chun.wang Bo-Chun Wang made changes -
          Field Original Value New Value
          Summary EE compact time elapsed in 7.1 EE compact time elapsed increased in 7.1
          james.lee James Lee made changes -
          Assignee Daniel Owen [ owend ] James Lee [ james.lee ]
          james.lee James Lee added a comment -

          Hi Bo-Chun Wang,

          Thanks for raising this, I hadn't noticed the regression until now. We haven't changed much around compaction (which is lucky) because it made finding this slightly easier. The only change that's been made to compaction was this one.

          This change switched over from using a bespoke worker pool, to a generic one which I added to out tools common library. In this change there's a somewhat subtle bug; we were never actually using the constructed worker pool i.e. compaction was always using a single thread.

          This wasn't picked up by the compiler because the worker pool itself was still referenced (to begin/block on teardown). I'll get a patch up to fix this issue (it's worth noting that this is a level above SQLite, so this will affect all storage types).

          Thanks,
          James

          james.lee James Lee added a comment - Hi Bo-Chun Wang , Thanks for raising this, I hadn't noticed the regression until now. We haven't changed much around compaction (which is lucky) because it made finding this slightly easier. The only change that's been made to compaction was this one. This change switched over from using a bespoke worker pool, to a generic one which I added to out tools common library. In this change there's a somewhat subtle bug; we were never actually using the constructed worker pool i.e. compaction was always using a single thread. This wasn't picked up by the compiler because the worker pool itself was still referenced (to begin/block on teardown). I'll get a patch up to fix this issue (it's worth noting that this is a level above SQLite, so this will affect all storage types). Thanks, James
          james.lee James Lee made changes -
          Link This issue is caused by MB-46367 [ MB-46367 ]
          james.lee James Lee made changes -
          Status Open [ 1 ] In Progress [ 3 ]

          Build couchbase-server-7.1.0-1124 contains backup commit 831fc4b with commit message:
          MB-47769 Correctly use the worker pool when compacting

          build-team Couchbase Build Team added a comment - Build couchbase-server-7.1.0-1124 contains backup commit 831fc4b with commit message: MB-47769 Correctly use the worker pool when compacting
          james.lee James Lee made changes -
          james.lee James Lee added a comment -

          Marking as resolved, please see the attached screenshot which indicates that we're back down to ~28s.

          james.lee James Lee added a comment - Marking as resolved, please see the attached screenshot which indicates that we're back down to ~28s.
          james.lee James Lee made changes -
          Assignee James Lee [ james.lee ] Bo-Chun Wang [ bo-chun.wang ]
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]

          I close this issue as the performance is back in build 1124.

          bo-chun.wang Bo-Chun Wang added a comment - I close this issue as the performance is back in build 1124.
          bo-chun.wang Bo-Chun Wang made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

          People

            bo-chun.wang Bo-Chun Wang
            bo-chun.wang Bo-Chun Wang
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty