Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-4781

start_key_docid returns unexpected (or unintuitive) results



      Below are the results from a query that returns multiple rows for a single key. The third document has id "0-8fbe114" but if I apply the start_key_docid filter I still get the same exact results with the list starting at doc id "0-14479a7." although the view should've returned a subset. I also tried start_key_docid in combination with start_key and end_key but neither of these returns a subset starting at the requested docid.

      QUERY WITH KEY = [2008,11,1]
      curl "" > query_with_key


      QUERY WITH KEY = [2008,11,1] and START_KEY_DOCID = "0-8fbe114"
      curl "" > query_with_startkeydocid

      ....results are the same as previous query, although I expected them to start with the requested doc_id...

      Also noticed that "id" and "_id" are mismatch - not sure if that has something to do with the behavior of this filter.

      1. query_with_key
        208 kB
        Tommie McAfee
      2. query_with_key_and_startkeydocid
        208 kB
        Tommie McAfee
      No reviews matched the request. Check your Options in the drop-down menu of this sections header.


        No work has yet been logged on this issue.


          • Assignee:
            BigBlueHat Benjamin Young
            tommie Tommie McAfee
          • Votes:
            0 Vote for this issue
            2 Start watching this issue


            • Due:

              Gerrit Reviews

              There are no open Gerrit changes