Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-47824

[Enforce-TLS]: "Infer error: Keyspace has no documents" after enforcing TLS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.0.1
    • Fix Version/s: 7.0.2
    • Component/s: query
    • Labels:
      None
    • Environment:
      Centos 7 64 bit; CB EE 7.0.1-5996

      Description

      Summary
      Infer statements executed after enforcing TLS result in the above mentioned error

      Steps to Reproduce

      1.  Create a 2 node cluster - .215 (kv), and .217(kv, n1ql)
      2. Load travel-sample bucket completely
      3. Navigate to Query page and observer the "Explore your data" for travel-sample's default keyspace. It shows number of documents
      4. Disable autofailover, and enable n2n encryption and set the level to "strict"
      5. Repeat the 3rd step. 
      shows error as "Infer error: Keyspace _default has no documents, schema inference not possible"

      (Might not be query component's issue, but assigning to query for first look)

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          isha Isha Kandaswamy added a comment -

          Duplicate of MB-47891


            People

            Assignee:
            isha Isha Kandaswamy
            Reporter:
            sumedh.basarkod Sumedh Basarkod
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty