Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-48279

Should allow graceful failover for query node without data service

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Not a Bug
    • Neo
    • Neo
    • ns_server, query
    • 7.1.0-1208
    • Untriaged
    • 1
    • Unknown

    Description

      If query will allow graceful failover we should allow CLI (and UI) to choose between graceful or hardfailover.

      For example:

      • setup 2 nodes cluster where 1 node is query ony
      • perform failover of query node via couchbase-cli

      # couchbase-cli failover -c localhost --username Administrator --password password --server-failover 172.23.120.102
      ERROR: Failover cannot be done gracefully for a node without data service. Use hard failover. 

      UI should also allow choice of graceful vs hard failover in the same case.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          Couchbase-cli passes the requests to failover to ns_server. The error above is returned from ns_server. As a result I have removed tools from the component list and added ns_sever.

          pvarley Patrick Varley added a comment - Couchbase-cli passes the requests to failover to ns_server. The error above is returned from ns_server . As a result I have removed tools from the component list and added ns_sever.
          meni.hillel Meni Hillel added a comment -

          Patrick Varley Since query does not have a state, "graceful" failover does not really make sense. I think it works as expected. If you have suggestion to change the behavior, you can file an enhancement and PM will need to make a call if and when we will address. If I misunderstood this ticket, please let me know.

          meni.hillel Meni Hillel added a comment - Patrick Varley Since query does not have a state, "graceful" failover does not really make sense. I think it works as expected. If you have suggestion to change the behavior, you can file an enhancement and PM will need to make a call if and when we will address. If I misunderstood this ticket, please let me know.
          kamini.jagtiani Kamini Jagtiani added a comment - - edited

          Hi Meni Hillel

          For Neo, as part of MB-47511, ns_server added query as a topology-aware service.

          As part of MB-40533, query now can do a graceful failover

          kamini.jagtiani Kamini Jagtiani added a comment - - edited Hi Meni Hillel For Neo, as part of  MB-47511 , ns_server added query as a topology-aware service. As part of  MB-40533 , query now can do a graceful failover
          meni.hillel Meni Hillel added a comment -

          Kamini Jagtiani The code clearly requires KV to be present on the node to allow graceful failover, regardless of which other services are present and whether they are topology aware or not. This had been addressed while back by MB-13947 when indexer was in context, which is also a topology aware service. So it is working as designed. If we want to change the behavior, please file an enhancement.

          meni.hillel Meni Hillel added a comment - Kamini Jagtiani The code clearly requires KV to be present on the node to allow graceful failover, regardless of which other services are present and whether they are topology aware or not. This had been addressed while back by MB-13947 when indexer was in context, which is also a topology aware service. So it is working as designed. If we want to change the behavior, please file an enhancement.

          People

            kamini.jagtiani Kamini Jagtiani
            pierre.regazzoni Pierre Regazzoni
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty