Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-48933

Pytpcc runs hit "panic serving: runtime error: invalid memory address or nil pointer dereference"

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate
    • Neo
    • Neo
    • secondary-index
    • Untriaged
    • 1
    • Unknown

    Description

      http://perf.jenkins.couchbase.com/job/hercules_nest_pytpcc_perfrunner_dev/155/

      We found panic messages in indexer.log. The run was running on build 7.1.0-1472.

      2021/10/14 10:45:50 http: panic serving 172.23.100.126:41712: runtime error: invalid memory address or nil pointer dereference2021/10/14 10:45:50 http: panic serving 172.23.100.126:41712: runtime error: invalid memory address or nil pointer dereferencegoroutine 360 [running]:net/http.(*conn).serve.func1(0xc004745e00) /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/net/http/server.go:1824 +0x153panic(0x11a5900, 0x1fc3870) /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/runtime/panic.go:971 +0x499github.com/couchbase/indexing/secondary/manager.(*requestHandlerContext).handleLocalIndexMetadataRequest(0x2048340, 0x15332a0, 0xc0059aaee0, 0xc0063cfc00) /home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/indexing/secondary/manager/request_handler.go:1731 +0xda0net/http.HandlerFunc.ServeHTTP(0xc004bbc780, 0x15332a0, 0xc0059aaee0, 0xc0063cfc00) /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/net/http/server.go:2069 +0x44net/http.(*ServeMux).ServeHTTP(0xc0004d7e00, 0x15332a0, 0xc0059aaee0, 0xc0063cfc00) /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/net/http/server.go:2448 +0x1adnet/http.serverHandler.ServeHTTP(0xc00026e2a0, 0x15332a0, 0xc0059aaee0, 0xc0063cfc00) /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/net/http/server.go:2887 +0xa3net/http.(*conn).serve(0xc004745e00, 0x153dfe0, 0xc006515cc0) /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/net/http/server.go:1952 +0x8cdcreated by net/http.(*Server).Serve /home/couchbase/.cbdepscache/exploded/x86_64/go-1.16.5/go/src/net/http/server.go:3013 +0x39b

      Logs:

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.121.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.122.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.123.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.124.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.125.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.126.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.127.zip

      https://s3.amazonaws.com/bugdb/jira/qe/collectinfo-2021-10-14T203348-ns_1%40172.23.100.128.zip

       

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          kevin.cherkauer Kevin Cherkauer added a comment - - edited

          Duplicate of MB-48869. Same LOC got nil pointer dereference:

          github.com/couchbase/indexing/secondary/manager.(*requestHandlerContext).handleLocalIndexMetadataRequest(0x2048340, 0x15332a0, 0xc0059aaee0, 0xc0063cfc00) /home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/indexing/secondary/manager/request_handler.go:1731

           

          The fix is available starting in Neo build couchbase-server-7.1.0-1483.

          kevin.cherkauer Kevin Cherkauer added a comment - - edited Duplicate of MB-48869 . Same LOC got nil pointer dereference: github.com/couchbase/indexing/secondary/manager.(*requestHandlerContext).handleLocalIndexMetadataRequest(0x2048340, 0x15332a0, 0xc0059aaee0, 0xc0063cfc00) /home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/indexing/secondary/manager/request_handler.go:1731   The fix is available starting in Neo build couchbase-server-7.1.0-1483.
          mihir.kamdar Mihir Kamdar added a comment -

          Bo-Chun Wang is this good in your latest runs ?

          mihir.kamdar Mihir Kamdar added a comment - Bo-Chun Wang is this good in your latest runs ?

          I have good runs. I will close this issue.

          bo-chun.wang Bo-Chun Wang added a comment - I have good runs. I will close this issue.

          People

            kevin.cherkauer Kevin Cherkauer
            bo-chun.wang Bo-Chun Wang
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty