Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-49255

TLS: Index UI not showing stats in Strict mode

    XMLWordPrintable

Details

    • Untriaged
    • 1
    • Unknown

    Description

      Build: 7.1.0-1601

      • Cluster with 2 data nodes and 4 index nodes (cluster spec attached)
      • setup root ca and load node certificate for each node
      • Load travel -sample
      • Enable TLS strict mode.
      • On UI, go to indexes tab and change view to "view by server node"

      Indexes are listed per node but stats are not.

      Indexes page:

      In the indexer logs we see below errors:

      2021-10-31T20:25:04.651-07:00 [Info] memstats {"Alloc":105197560, "TotalAlloc":3616140072, "Sys":286320696, "Lookups":0, "Mallocs":27790004,"Frees":27682057, "HeapAlloc":105197560, "HeapSys":262275072, "HeapIdle":128237568, "HeapInuse":134037504,"HeapReleased":56524800, "HeapObjects":107947,"MSpanInuse":798456, "MSpanSys": 1474560, "StackInuse": 6160384,"GCSys":13531200, "LastGC":1635737092052819119,"PauseTotalNs":7397521, "PauseNs":[128913], "NumGC":65}
      2021-10-31T20:25:05.060-07:00 [Info] RebalanceServiceManager::rebalanceJanitor Running Periodic Cleanup
      2021-10-31T20:25:06.191-07:00 [Info] RebalanceServiceManager::GetCurrentTopology []
      2021-10-31T20:25:06.192-07:00 [Info] RebalanceServiceManager::GetCurrentTopology returns &{[0 0 0 0 0 0 0 2] [d2a5d2d7451145a729fe67d23cf39312 95a9da7427469a1266633888e57aca84 2d20b27a88308f40ad07d0533fcdf75f fb454c8721a05e984aec56224440ccaa] true []}
      2021-10-31T20:25:06.192-07:00 [Info] RebalanceServiceManager::GetTaskList []
      2021-10-31T20:25:06.192-07:00 [Info] RebalanceServiceManager::GetTaskList returns &{[0 0 0 0 0 0 0 2] []}
      2021-10-31T20:25:06.193-07:00 [Info] RebalanceServiceManager::GetTaskList [0 0 0 0 0 0 0 2]
      2021-10-31T20:25:06.193-07:00 [Info] RebalanceServiceManager::GetCurrentTopology [0 0 0 0 0 0 0 2]
      2021-10-31T20:25:07.317-07:00 [Error] PeerPipe.doRecieve() : ecounter error when received mesasage from Peer 172.23.120.174:59898.  Error = tls: first record does not look like a TLS handshake. Kill Pipe.
      2021-10-31T20:25:07.317-07:00 [Error] LeaderSyncProxy.updateAcceptEpochAfterQuorum(): Error encountered = Server Error : SyncProxy.listen(): channel closed. Terminate
      2021-10-31T20:25:07.317-07:00 [Error] LeaderServer:startProxy(): Leader Fail to synchronization with follower (TCP conn = 172.23.120.174:59898)
      2021-10-31T20:25:07.320-07:00 [Error] PeerPipe.doRecieve() : ecounter error when received mesasage from Peer 172.23.97.211:37940.  Error = tls: first record does not look like a TLS handshake. Kill Pipe.
      2021-10-31T20:25:07.320-07:00 [Error] LeaderSyncProxy.updateAcceptEpochAfterQuorum(): Error encountered = Server Error : SyncProxy.listen(): channel closed. Terminate
      2021-10-31T20:25:07.320-07:00 [Error] LeaderServer:startProxy(): Leader Fail to synchronization with follower (TCP conn = 172.23.97.211:37940)
      

      Cluster spec:

      Logs:

      https://cb-jira.s3.us-east-2.amazonaws.com/logs/tls/collectinfo-2021-11-01T032638-ns_1%40172.23.100.11.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/tls/collectinfo-2021-11-01T032638-ns_1%40172.23.100.13.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/tls/collectinfo-2021-11-01T032638-ns_1%40172.23.120.174.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/tls/collectinfo-2021-11-01T032638-ns_1%40172.23.96.141.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/tls/collectinfo-2021-11-01T032638-ns_1%40172.23.97.211.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/tls/collectinfo-2021-11-01T032638-ns_1%40172.23.97.212.zip

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            cc Dave Finlay Jeelan Poola

            Sai Krishna Teja the UI issue is the same as in MB-50111 and it has been decided in the maintenance issue to not fix it in 6.6.5. I see no point in keeping this issue open in that case.

            mihir.kamdar Mihir Kamdar (Inactive) added a comment - cc Dave Finlay Jeelan Poola Sai Krishna Teja the UI issue is the same as in MB-50111 and it has been decided in the maintenance issue to not fix it in 6.6.5. I see no point in keeping this issue open in that case.
            sai.teja Sai Krishna Teja added a comment - - edited

            Thanks Mihir Kamdar will resolve this issue as done. We can use MB-50111 for 6.6.5

            sai.teja Sai Krishna Teja added a comment - - edited Thanks Mihir Kamdar will resolve this issue as done. We can use MB-50111 for 6.6.5

            So, as the API fix verification is done for 6.6.5 and as UI looks good for Neo after the fix, closing this issue.

            girish.benakappa Girish Benakappa added a comment - So, as the API fix verification is done for 6.6.5 and as UI looks good for Neo after the fix, closing this issue.
            wayne Wayne Siu added a comment -

            Girish Benakappa 

            Can you also verify the fix in 7.0.4?  Thanks.

            wayne Wayne Siu added a comment - Girish Benakappa   Can you also verify the fix in 7.0.4?  Thanks.

            Verified with 7.0.4 build 7217

            girish.benakappa Girish Benakappa added a comment - Verified with 7.0.4 build 7217

            People

              girish.benakappa Girish Benakappa
              girish.benakappa Girish Benakappa
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                PagerDuty