Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-50946

[BP MB-49874 to 6.6.x] - FTS: bleveMaxClauseCount reset to 1024 after restart

    XMLWordPrintable

Details

    • Untriaged
    • 1
    • Unknown

    Description

      Build: 7.1.0-1787

      • Create fts cluster
      • Create a bucket and index on it
      • Run a query which hits bleveMaxClauseCount greater than 1024
      • set bleveMaxClauseCount to greater than what above query needs
      • verify the value set with conciseOptions API
      • run the same query - query runs fine
      • restart fts
      • run the same query again - query fails with bleveMaxClauseCount

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            wayne Wayne Siu created issue -
            wayne Wayne Siu made changes -
            Field Original Value New Value
            Link This issue Clones MB-49874 [ MB-49874 ]
            wayne Wayne Siu made changes -
            Link This issue is a backport of MB-49874 [ MB-49874 ]
            wayne Wayne Siu made changes -
            Link This issue Clones MB-49874 [ MB-49874 ]
            wayne Wayne Siu made changes -
            Link This issue blocks MB-50945 [ MB-50945 ]
            wayne Wayne Siu made changes -
            Link This issue blocks MB-48997 [ MB-48997 ]
            wayne Wayne Siu made changes -
            Assignee Girish Benakappa [ girish.benakappa ] Abhinav Dangeti [ abhinav ]
            wayne Wayne Siu made changes -
            Summary [BP MB-49874 to 6.6.x] - CLONE - FTS: bleveMaxClauseCount reset to 1024 after restart [BP MB-49874 to 6.6.x] - FTS: bleveMaxClauseCount reset to 1024 after restart
            abhinav Abhi Dangeti added a comment - https://review.couchbase.org/c/cbgt/+/170677 https://review.couchbase.org/c/cbft/+/170678
            abhinav Abhi Dangeti made changes -
            Fix Version/s 6.6.6 [ 18032 ]
            abhinav Abhi Dangeti added a comment -

            Wayne Siu The mad-hatter backports are complete. Once a plan for 7.0.4 (or other 7.0.x) is ready, these are the back ports for the cheshire-cat branches ..

            abhinav Abhi Dangeti added a comment - Wayne Siu The mad-hatter backports are complete. Once a plan for 7.0.4 (or other 7.0.x) is ready, these are the back ports for the cheshire-cat branches .. https://review.couchbase.org/c/cbgt/+/170686 https://review.couchbase.org/c/cbft/+/170687
            abhinav Abhi Dangeti made changes -
            Fix Version/s 7.0.x [ 18258 ]

            Build couchbase-server-6.6.5-10083 contains cbft commit 8d80ea0 with commit message:
            MB-50946: [BP] bleveMaxClauseCount reset to 1024 after restart

            build-team Couchbase Build Team added a comment - Build couchbase-server-6.6.5-10083 contains cbft commit 8d80ea0 with commit message: MB-50946 : [BP] bleveMaxClauseCount reset to 1024 after restart

            Build couchbase-server-6.6.5-10083 contains cbgt commit 8105e42 with commit message:
            MB-50946: [BP] bleveMaxClauseCount reset to 1024 after restart

            build-team Couchbase Build Team added a comment - Build couchbase-server-6.6.5-10083 contains cbgt commit 8105e42 with commit message: MB-50946 : [BP] bleveMaxClauseCount reset to 1024 after restart
            abhinav Abhi Dangeti made changes -
            Affects Version/s Neo [ 17615 ]
            abhinav Abhi Dangeti made changes -
            Fix Version/s Neo [ 17615 ]

            Abhi Dangeti I could able to reproduce the issue with 6.6.5-10083 (with fixes).
            And also since fix for MB-44093 is not in 6.6.5, we cannot see the set value in conciseOptions

            girish.benakappa Girish Benakappa added a comment - Abhi Dangeti I could able to reproduce the issue with 6.6.5-10083 (with fixes). And also since fix for MB-44093 is not in 6.6.5, we cannot see the set value in conciseOptions
            abhinav Abhi Dangeti made changes -
            Link This issue relates to MB-46721 [ MB-46721 ]
            abhinav Abhi Dangeti made changes -
            Link This issue relates to MB-46721 [ MB-46721 ]
            abhinav Abhi Dangeti added a comment -

            Thanks Girish Benakappa . You should be able to use this endpoint to look at the settings ..

            curl -XGET -H "Content-type:application/json" -u <username>:<password> http://<ip>:8094/api/manager 

            The conciseOptions is an endpoint we added later for our UI to hit and obtain a very minimal set of settings.

            It seems we'll need to backport one other change - https://review.couchbase.org/c/cbgt/+/170921

            A build should become available soon with it.

            abhinav Abhi Dangeti added a comment - Thanks Girish Benakappa . You should be able to use this endpoint to look at the settings .. curl -XGET -H "Content-type:application/json" -u <username>:<password> http: //<ip>:8094/api/manager The conciseOptions is an endpoint we added later for our UI to hit and obtain a very minimal set of settings. It seems we'll need to backport one other change - https://review.couchbase.org/c/cbgt/+/170921 A build should become available soon with it.

            Build couchbase-server-6.6.5-10085 contains cbgt commit 464369d with commit message:
            MB-50946: [BP] Extending clusterOptions with bleveMaxClauseCount

            build-team Couchbase Build Team added a comment - Build couchbase-server-6.6.5-10085 contains cbgt commit 464369d with commit message: MB-50946 : [BP] Extending clusterOptions with bleveMaxClauseCount

            Verified with 6.6.5-10085

            girish.benakappa Girish Benakappa added a comment - Verified with 6.6.5-10085
            lynn.straus Lynn Straus made changes -
            Link This issue blocks MB-51129 [ MB-51129 ]
            lynn.straus Lynn Straus made changes -
            Link This issue blocks MB-51129 [ MB-51129 ]
            wayne Wayne Siu made changes -
            Labels candidate-for-6.6.6 candidate-for-6.6.6 candidate-for-7.0.4
            wayne Wayne Siu made changes -
            Fix Version/s 7.0.4 [ 18322 ]
            Fix Version/s 7.0.x [ 18258 ]
            abhinav Abhi Dangeti made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]

            Build couchbase-server-7.0.4-7217 contains cbft commit 55f64de with commit message:
            MB-50946: [BP] bleveMaxClauseCount reset to 1024 after restart

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.4-7217 contains cbft commit 55f64de with commit message: MB-50946 : [BP] bleveMaxClauseCount reset to 1024 after restart

            Build couchbase-server-7.0.4-7217 contains cbgt commit c87996d with commit message:
            MB-50946: [BP] bleveMaxClauseCount reset to 1024 after restart

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.4-7217 contains cbgt commit c87996d with commit message: MB-50946 : [BP] bleveMaxClauseCount reset to 1024 after restart
            wayne Wayne Siu made changes -
            Labels candidate-for-6.6.6 candidate-for-7.0.4 approved-for-7.0.4 candidate-for-6.6.6 candidate-for-7.0.4
            wayne Wayne Siu made changes -
            Assignee Abhinav Dangeti [ abhinav ] Girish Benakappa [ girish.benakappa ]

            Verified with 7.0.4-7217

            girish.benakappa Girish Benakappa added a comment - Verified with 7.0.4-7217
            girish.benakappa Girish Benakappa made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            wayne Wayne Siu made changes -
            Link This issue blocks MB-53812 [ MB-53812 ]
            wayne Wayne Siu made changes -
            Labels approved-for-7.0.4 candidate-for-6.6.6 candidate-for-7.0.4 approved-for-6.6.6 approved-for-7.0.4 candidate-for-6.6.6 candidate-for-7.0.4

            People

              girish.benakappa Girish Benakappa
              girish.benakappa Girish Benakappa
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                PagerDuty