Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-54059

kv-post commit job for cheshire-cat is failing

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • Cheshire-Cat
    • backlog
    • build
    • None
    • Untriaged
    • 1
    • Unknown

    Attachments

      Issue Links

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          owend Daniel Owen added a comment -

          Looking at the latest error linked by Trond Norbye

          -- Installing: /home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/install/bin/mcctl
          CMake Error at kv_engine/programs/mcctl/cmake_install.cmake:52 (file):
            file INSTALL cannot copy file
            "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/build/kv_engine/mcctl"
            to
            "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/install/bin/mcctl":
            Success.
          Call Stack (most recent call first):
            kv_engine/programs/cmake_install.cmake:51 (include)
            kv_engine/cmake_install.cmake:64 (include)
            cmake_install.cmake:111 (include)
           
           
          Makefile:92: recipe for target 'install' failed
          make[2]: *** [install] Error 1
          Makefile:37: recipe for target 'compile' failed
          make[1]: *** [compile] Error 2
          GNUmakefile:16: recipe for target 'all' failed
          make: *** [all] Error 2
          Build step 'Execute shell' marked build as failure
          Archiving artifacts
          [Address Sanitizer] Skipping execution of recorder since overall result is 'FAILURE'
          Sending e-mails to: kv_engine_dev@couchbase.com
          ERROR: Build step failed with exception
          java.lang.NumberFormatException: null
          	at java.base/java.lang.Integer.parseInt(Integer.java:614)
          	at java.base/java.lang.Integer.parseInt(Integer.java:770)
          	at org.jenkinsci.plugins.verifystatus.VerificationsPublisher.perform(VerificationsPublisher.java:177)
          	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:814)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:763)
          	at hudson.model.Build$BuildExecution.cleanUp(Build.java:189)
          	at hudson.model.Run.execute(Run.java:1943)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:44)
          	at hudson.model.ResourceController.execute(ResourceController.java:101)
          	at hudson.model.Executor.run(Executor.java:442)
          Build step 'Post Verification to Gerrit' marked build as failure
          [WS-CLEANUP] Deleting project workspace...
          [WS-CLEANUP] done
          Finished: FAILURE
          

          owend Daniel Owen added a comment - Looking at the latest error linked by Trond Norbye -- Installing: /home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/install/bin/mcctl CMake Error at kv_engine/programs/mcctl/cmake_install.cmake:52 (file): file INSTALL cannot copy file "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/build/kv_engine/mcctl" to "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/install/bin/mcctl": Success. Call Stack (most recent call first): kv_engine/programs/cmake_install.cmake:51 (include) kv_engine/cmake_install.cmake:64 (include) cmake_install.cmake:111 (include)     Makefile:92: recipe for target 'install' failed make[2]: *** [install] Error 1 Makefile:37: recipe for target 'compile' failed make[1]: *** [compile] Error 2 GNUmakefile:16: recipe for target 'all' failed make: *** [all] Error 2 Build step 'Execute shell' marked build as failure Archiving artifacts [Address Sanitizer] Skipping execution of recorder since overall result is 'FAILURE' Sending e-mails to: kv_engine_dev@couchbase.com ERROR: Build step failed with exception java.lang.NumberFormatException: null at java.base/java.lang.Integer.parseInt(Integer.java:614) at java.base/java.lang.Integer.parseInt(Integer.java:770) at org.jenkinsci.plugins.verifystatus.VerificationsPublisher.perform(VerificationsPublisher.java:177) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:814) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:763) at hudson.model.Build$BuildExecution.cleanUp(Build.java:189) at hudson.model.Run.execute(Run.java:1943) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:44) at hudson.model.ResourceController.execute(ResourceController.java:101) at hudson.model.Executor.run(Executor.java:442) Build step 'Post Verification to Gerrit' marked build as failure [WS-CLEANUP] Deleting project workspace... [WS-CLEANUP] done Finished: FAILURE
          owend Daniel Owen added a comment -

          So it looks like the issue is

          CMake Error at kv_engine/programs/mcctl/cmake_install.cmake:52 (file):
            file INSTALL cannot copy file
            "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/build/kv_engine/mcctl"
            to
            "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/install/bin/mcctl":
            Success.
          

          owend Daniel Owen added a comment - So it looks like the issue is CMake Error at kv_engine/programs/mcctl/cmake_install.cmake:52 (file): file INSTALL cannot copy file "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/build/kv_engine/mcctl" to "/home/couchbase/jenkins/workspace/kv_engine-post-commit-cheshire-cat/install/bin/mcctl": Success.
          owend Daniel Owen added a comment -

          Looks like mcctl got built correctly

          [ 85%] Linking CXX executable ../../mcctl
          [ 85%] Built target mcctl
          

          owend Daniel Owen added a comment - Looks like mcctl got built correctly [ 85%] Linking CXX executable ../../mcctl [ 85%] Built target mcctl
          owend Daniel Owen added a comment -

          Its unclear why the copy failed. I assume either

          • insufficient space
          • target directory not exist (if did exist - but perhaps it was subsequently deleted)
          • permissions issue

          Chris Hillery / Dave Rigby I'm stuck from here..

          owend Daniel Owen added a comment - Its unclear why the copy failed. I assume either insufficient space target directory not exist (if did exist - but perhaps it was subsequently deleted) permissions issue Chris Hillery / Dave Rigby I'm stuck from here..

          I'm guessing you're right about running out of space - the agents try to clean up enough space but it's sometimes a losing battle. Weird that the error message is "Success", though. I googled for that but didn't immediately find a similar reference.

          Regardless, that looks like a completely different kind of error than the originally reported one, so if it recurs, please file a new ticket.

          ceej Chris Hillery added a comment - I'm guessing you're right about running out of space - the agents try to clean up enough space but it's sometimes a losing battle. Weird that the error message is "Success", though. I googled for that but didn't immediately find a similar reference. Regardless, that looks like a completely different kind of error than the originally reported one, so if it recurs, please file a new ticket.

          People

            trond Trond Norbye
            trond Trond Norbye
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty