Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-54104

Dead Analytics service following a system restart

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Software failure
    • 7.1.1
    • 7.1.4
    • analytics
    • Macbook Pro with macOS Big Sur v 11.6.8 (20G730)
      CB Server Enterprise Edition 7.1.1 build 3175 ‧ IPv4
    • Untriaged
    • MacOSX 64-bit
    • 1
    • Unknown

    Description

      (IN THE ANALYTICS TAB)

      Received error 500 when contacting the analytics service. Try refreshing the browser, as errors may occur if the analytics service is still warming up or suffering a transient error.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          wail.alkowaileet Wail Alkowaileet added a comment - - edited

          The issue is the JVM was (for some unknown reason) crashing while running a GC task:

          Stack:

          Stack: [0x00007000086a2000,0x00007000087a2000],  sp=0x00007000087a1d30,  free space=1023k
          Native frames: (J=compiled Java code, A=aot compiled Java code, j=interpreted, Vv=VM code, C=native code)
          V  [libjvm.dylib+0x679e15]  _ZN18PSPromotionManager22copy_to_survivor_spaceILb0EEEP7oopDescS2_+0xc9
          V  [libjvm.dylib+0x67d39d]  _ZN18PSPromotionManager29process_popped_location_depthE8StarTask+0xf9
          V  [libjvm.dylib+0x678bc8]  _ZN18PSPromotionManager18drain_stacks_depthEb+0x188
          V  [libjvm.dylib+0x67d19b]  _ZN9StealTask5do_itEP13GCTaskManagerj+0x2f
          V  [libjvm.dylib+0x355bde]  _ZN12GCTaskThread3runEv+0x11e
          V  [libjvm.dylib+0x77bc04]  _ZN6Thread8call_runEv+0x68
          V  [libjvm.dylib+0x629fd7]  _ZL19thread_native_entryP6Thread+0x139
          C  [libsystem_pthread.dylib+0x68fc]  _pthread_start+0xe0
          C  [libsystem_pthread.dylib+0x2443]  thread_start+0xf
          
          

           

          Failing thread:

          =>0x00007ff5c9b30800 GCTaskThread "ParGC Thread#5" [stack: 0x00007000086a2000,0x00007000087a2000] [id=30723]

           

          Upgrading the JVM to jdk-11.0.16.1+1 solved the issue.

          wail.alkowaileet Wail Alkowaileet added a comment - - edited The issue is the JVM was (for some unknown reason) crashing while running a GC task: Stack: Stack: [ 0x00007000086a2000 , 0x00007000087a2000 ], sp= 0x00007000087a1d30 , free space=1023k Native frames: (J=compiled Java code, A=aot compiled Java code, j=interpreted, Vv=VM code, C= native code) V [libjvm.dylib+ 0x679e15 ] _ZN18PSPromotionManager22copy_to_survivor_spaceILb0EEEP7oopDescS2_+ 0xc9 V [libjvm.dylib+ 0x67d39d ] _ZN18PSPromotionManager29process_popped_location_depthE8StarTask+ 0xf9 V [libjvm.dylib+ 0x678bc8 ] _ZN18PSPromotionManager18drain_stacks_depthEb+ 0x188 V [libjvm.dylib+ 0x67d19b ] _ZN9StealTask5do_itEP13GCTaskManagerj+ 0x2f V [libjvm.dylib+ 0x355bde ] _ZN12GCTaskThread3runEv+ 0x11e V [libjvm.dylib+ 0x77bc04 ] _ZN6Thread8call_runEv+ 0x68 V [libjvm.dylib+ 0x629fd7 ] _ZL19thread_native_entryP6Thread+ 0x139 C [libsystem_pthread.dylib+ 0x68fc ] _pthread_start+ 0xe0 C [libsystem_pthread.dylib+ 0x2443 ] thread_start+ 0xf   Failing thread: => 0x00007ff5c9b30800 GCTaskThread "ParGC Thread#5" [stack: 0x00007000086a2000 , 0x00007000087a2000 ] [id= 30723 ]   Upgrading the JVM to jdk-11.0.16.1+1 solved the issue.

          Additional information:

          At first, when launching Couchbase Server, the error seems to be gone using the older JVM. However, when we changed the memory size allocated for Analytics, the problem came back again. After upgrading the JVM, the issue was solved. We resized the memory for Analytics again and it worked as expected.

          wail.alkowaileet Wail Alkowaileet added a comment - Additional information: At first, when launching Couchbase Server, the error seems to be gone using the older JVM. However, when we changed the memory size allocated for Analytics, the problem came back again. After upgrading the JVM, the issue was solved. We resized the memory for Analytics again and it worked as expected.

          People

            wail.alkowaileet Wail Alkowaileet
            mike.carey Mike Carey
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty