Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-54216

Concurrent databases creation aborts the sample data loading for few if there is a rebalance triggered for any valid reason.

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate
    • Elixir
    • None
    • tools
    • None
    • 7.5.0-3081

    Description

      When a rebalance being triggered immediately after the bucket creation which is trying to load sample data, sample data loading for that bucket fails.

      Steps to reproduce:

      1. Create 10 databases with a pause of 1sec between each database creation.
      2. Create another database and immediately trigger rebalance by let's say updating the width for any existing database or set balance=False by changing weights.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          james.lee James Lee added a comment -

          On our end, things are behaving as defined (although perhaps not as desired).

          2022-10-19T22:41:22.072+00:00 WARN: (REST) (Attempt 1) (POST) Request to endpoint '/pools/default/buckets/volumetestbucket-3-xk5r37' failed with status code 503 -- logging.(*ToolsCommonLogger).Log() at tools_common.go:28
          

          We're failing to perform a POST with a 503 (service unavailable). Our REST client is correctly not retrying this request because POST requests aren't idempotent (as they can have side-effects).

          Steve Watanabe are POST requests for bucket update idempotent (e.g. we could force retries on our end)?

          james.lee James Lee added a comment - On our end, things are behaving as defined (although perhaps not as desired). 2022-10-19T22:41:22.072+00:00 WARN: (REST) (Attempt 1) (POST) Request to endpoint '/pools/default/buckets/volumetestbucket-3-xk5r37' failed with status code 503 -- logging.(*ToolsCommonLogger).Log() at tools_common.go:28 We're failing to perform a POST with a 503 (service unavailable). Our REST client is correctly not retrying this request because POST requests aren't idempotent (as they can have side-effects). Steve Watanabe are POST requests for bucket update idempotent (e.g. we could force retries on our end)?

          James Lee why do we need to update the bucket?

          shelby.ramsey Shelby Ramsey added a comment - James Lee why do we need to update the bucket?
          james.lee James Lee added a comment - - edited

          James Lee why do we need to update the bucket?

          Ah, I should remember which MBs I've created. Yes, we do already plan to remove this functionality for Elixir (MB-54268) so this issue will disappear with that.

          I would still like to see what Steve says about the endpoints when getting 503 status though as this would apply to 'cbimport' and 'cbbackpumgr restore' in other use-cases; I'd be good to see if we could make them more resilient in general.

          james.lee James Lee added a comment - - edited James Lee why do we need to update the bucket? Ah, I should remember which MBs I've created. Yes, we do already plan to remove this functionality for Elixir (MB-54268) so this issue will disappear with that. I would still like to see what Steve says about the endpoints when getting 503 status though as this would apply to ' cbimport ' and ' cbbackpumgr restore ' in other use-cases; I'd be good to see if we could make them more resilient in general.

          Sorry James Lee I didn't see your prior update. An update to a bucket via the REST endpoint should be idempotent. Otherwise the bucket might be left in some unknown, inconsistent state.

          steve.watanabe Steve Watanabe added a comment - Sorry James Lee I didn't see your prior update. An update to a bucket via the REST endpoint should be idempotent. Otherwise the bucket might be left in some unknown, inconsistent state.
          james.lee James Lee added a comment -

          That's perfect, thanks Steve Watanabe I'll get that updated in MB-54325.

          Marking this issue as a duplicate of MB-54268 since we'll be removing the functionality to modify the bucket for Elixir in that ticket.

          james.lee James Lee added a comment - That's perfect, thanks Steve Watanabe I'll get that updated in MB-54325 . Marking this issue as a duplicate of MB-54268 since we'll be removing the functionality to modify the bucket for Elixir in that ticket.

          People

            ritesh.agarwal Ritesh Agarwal
            ritesh.agarwal Ritesh Agarwal
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty