Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-6613

(MacOS) startup time (restart) is quite long considering the number of items on recent builds

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: bug-backlog
    • Component/s: None
    • Security Level: Public
    • Environment:
      Mac OS X 10.6.8, 266 GHz Intel Core 2 Duo, 8GB memory, Couchbase Server 2.0 build 1700
    • Triage:
      Untriaged
    • Link to Log File, atop/blg, CBCollectInfo, Core dump:
      a

      Description

      I happened to notice the web UI took quite a while to come up after a restart, especially relative to the number of items.

      Timing it, I see:

      • Web UI is up in about 40 seconds
      • CPU utilization continues for about another minute

      The system was run through a set of unit tests that delete and recreate the default bucket quite a bit, but at the end there were only 144 items. It seems like about 1 second per item for startup is pretty long.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        ingenthr Matt Ingenthron added a comment -

        I just re-ran this test and the good news is it's much better. 3 seconds with Version: 2.2.0 enterprise edition (build-821)

        Show
        ingenthr Matt Ingenthron added a comment - I just re-ran this test and the good news is it's much better. 3 seconds with Version: 2.2.0 enterprise edition (build-821)
        Hide
        alkondratenko Aleksey Kondratenko (Inactive) added a comment -

        removed this off my list

        Show
        alkondratenko Aleksey Kondratenko (Inactive) added a comment - removed this off my list
        Hide
        ingenthr Matt Ingenthron added a comment -

        couchbase-core/var/lib/couchbase/logs is empty

        I've attached the logs from Library/Logs/

        Show
        ingenthr Matt Ingenthron added a comment - couchbase-core/var/lib/couchbase/logs is empty I've attached the logs from Library/Logs/
        Hide
        ingenthr Matt Ingenthron added a comment -

        Oh, note that this is a regression. The UI used to be available immediately after restart, or immediately enough that I didn't even think about it. Since about build 1495.

        Show
        ingenthr Matt Ingenthron added a comment - Oh, note that this is a regression. The UI used to be available immediately after restart, or immediately enough that I didn't even think about it. Since about build 1495.
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        can you please attach logs from the machine

        zipping everythng under couchbase-core/var/lib/couchbase/logs

        Show
        farshid Farshid Ghods (Inactive) added a comment - can you please attach logs from the machine zipping everythng under couchbase-core/var/lib/couchbase/logs

          People

          • Assignee:
            alkondratenko Aleksey Kondratenko (Inactive)
            Reporter:
            ingenthr Matt Ingenthron
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes