Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-6841

XDCR fails when admin password contains special characters

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: ns_server
    • Security Level: Public
    • Labels:
      None
    No reviews matched the request. Check your Options in the drop-down menu of this sections header.

      Activity

      Hide
      dipti Dipti Borkar added a comment -

      changes on gerrit.

      Show
      dipti Dipti Borkar added a comment - changes on gerrit.
      Show
      alkondratenko Aleksey Kondratenko (Inactive) added a comment - http://review.couchbase.org/#/c/21461/
      Hide
      ketaki Ketaki Gangal added a comment -

      Tested on 1874, no longer seeing this issue.

      Show
      ketaki Ketaki Gangal added a comment - Tested on 1874, no longer seeing this issue.
      Hide
      scalabl3 scalabl3 added a comment -

      A user on IRC reported this issue with 2.0 and XDCR, he had a password with an @ in it.

      <Phibs> so replication definitely fails when the password has special chars such as @ in it
      <Phibs> you guys need to escape/encode that stuff
      <Phibs> http://www.bsd-unix.net/seitz/jing/2013-03-08_1406.png
      <scalabl3> i was just clarifying that you saw that bug appear again in the right place, meaning it was XDCR, not just "in-cluster" replica's
      <Phibs> it was under 'create replication'
      <Phibs> the last 10 errors button showed up under 'status'
      <Phibs> vs 'replicating'
      <Phibs> and it had my password listed (minus the @) as ["Firstpart","Secondpart"] and failures

      he solved it by changing his password...

      Show
      scalabl3 scalabl3 added a comment - A user on IRC reported this issue with 2.0 and XDCR, he had a password with an @ in it. <Phibs> so replication definitely fails when the password has special chars such as @ in it <Phibs> you guys need to escape/encode that stuff <Phibs> http://www.bsd-unix.net/seitz/jing/2013-03-08_1406.png <scalabl3> i was just clarifying that you saw that bug appear again in the right place, meaning it was XDCR, not just "in-cluster" replica's <Phibs> it was under 'create replication' <Phibs> the last 10 errors button showed up under 'status' <Phibs> vs 'replicating' <Phibs> and it had my password listed (minus the @) as ["Firstpart","Secondpart"] and failures he solved it by changing his password...
      Hide
      farshid Farshid Ghods (Inactive) added a comment -

      so looks like this issue is not fixed yet , or at least for the special char '@'

      Show
      farshid Farshid Ghods (Inactive) added a comment - so looks like this issue is not fixed yet , or at least for the special char '@'

        People

        • Assignee:
          alkondratenko Aleksey Kondratenko (Inactive)
          Reporter:
          mikew Mike Wiederhold
        • Votes:
          0 Vote for this issue
          Watchers:
          3 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Gerrit Reviews

            There are no open Gerrit changes