Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-7295

Upgrade docs for 2.0 don't seem accurate

    Details

      Description

      According to this page: http://www.couchbase.com/docs/couchbase-manual-2.0/couchbase-getting-started-upgrade-individual.html

      The upgrade process should be an rpm U, but that doesn't work when going from 1.8>2.0:
      rpm -U couchbase-server-community_x86_64_2.0.0-beta.rpm
      Stopping couchbase-server ...
      Stopping couchbase-serverNOTE: shutdown failed

      {badrpc,nodedown}

      Upgrading couchbase-server ...
      /opt/couchbase/bin/install/cbupgrade -c /opt/couchbase/var/lib/couchbase/config -a yes
      Traceback (most recent call last):
      File "/opt/couchbase/bin/install/cbupgrade", line 11, in ?
      import sqlite3
      ImportError: No module named sqlite3
      Starting couchbase-server[ OK ]

      You have successfully installed Couchbase Server.
      Please browse to http://fcddeva01:8091/ to configure your server.
      Please refer to http://couchbase.com for additional resources.

      Please note that you have to update your firewall configuration to
      allow connections to the following ports: 11211, 11210, 11209, 4369,
      8091 and from 21100 to 21299.

      By using this software you agree to the End User License Agreement.
      See /opt/couchbase/LICENSE.txt.

      Stopping couchbase-serverNOTE: shutdown failed {badrpc,nodedown}

      --------------------------------------

      I was under the impression that we were not supporting an in-place upgrade from 1.8 to 2.0, this upgrade scenario needs to be addressed and called out specifically as it will be frequently referred to and used by our existing customers.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        perry Perry Krug added a comment -

        No, the comment is about going from 1.8 TO pre-GA releases...which does not work and is not supported. That's what I want called out.

        Show
        perry Perry Krug added a comment - No, the comment is about going from 1.8 TO pre-GA releases...which does not work and is not supported. That's what I want called out.
        Hide
        mccouch MC Brown (Inactive) added a comment -

        That information is where it should be, in the release notes.

        Show
        mccouch MC Brown (Inactive) added a comment - That information is where it should be, in the release notes.
        Hide
        mccouch MC Brown (Inactive) added a comment -

        Documentation has been updated.

        Show
        mccouch MC Brown (Inactive) added a comment - Documentation has been updated.
        Hide
        perry Perry Krug added a comment -

        MC, I don't understand why this is so hard. People are not getting the information from the release notes, they are making mistakes, I'm asking you to help prevent that.

        Show
        perry Perry Krug added a comment - MC, I don't understand why this is so hard. People are not getting the information from the release notes, they are making mistakes, I'm asking you to help prevent that.
        Hide
        mccouch MC Brown (Inactive) added a comment -

        First of all, the documentation very clearly states, in each of the upgrade sections, that upgrades are only supported between 1.8 and 2.0. It does not say 2.0 beta, 2.0 pre-release, or any other combination other than 2.0.

        Second, in the recent fix I committed, but which has been built yet, I have added a note about the incompatibility with beta and pre-release versions.

        Show
        mccouch MC Brown (Inactive) added a comment - First of all, the documentation very clearly states, in each of the upgrade sections, that upgrades are only supported between 1.8 and 2.0. It does not say 2.0 beta, 2.0 pre-release, or any other combination other than 2.0. Second, in the recent fix I committed, but which has been built yet, I have added a note about the incompatibility with beta and pre-release versions.

          People

          • Assignee:
            mccouch MC Brown (Inactive)
            Reporter:
            perry Perry Krug
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes