Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-7482

[RN 2.0.1]Add Minimal system requirements on Couchbase 2.0 Server installation

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: tools
    • Security Level: Public
    • Flagged:
      Release Note

      Description

      Refer bug http://www.couchbase.com/issues/browse/CBQE-945.

      Currently customers w/ under-sized clusters will run into numerous timeouts/issues.

      There should be a warning letting the users know the minimal system requirements on 2.0 installation.

      # Subject Project Status CR V
      For Gerrit Dashboard: &For+MB-7482=message:MB-7482

        Activity

        Hide
        perry Perry Krug added a comment -

        If it hasn't started already, it would be very helpful to either use this bug or a wiki page to get a wider consensus on what these minimal requirements should be, how they should be expressed to the customer and how they should be enforced at a software level.

        Show
        perry Perry Krug added a comment - If it hasn't started already, it would be very helpful to either use this bug or a wiki page to get a wider consensus on what these minimal requirements should be, how they should be expressed to the customer and how they should be enforced at a software level.
        Hide
        steve Steve Yen added a comment -

        Another place to put this would possibly be in the setup wizard screens (ns_server), so that any checks are cross-platform.

        Or, in healthchecker.

        Show
        steve Steve Yen added a comment - Another place to put this would possibly be in the setup wizard screens (ns_server), so that any checks are cross-platform. Or, in healthchecker.
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        per bug scrub

        the warning message can appear during or after setup is completed.
        on linux this warning will appear in the terminal. on windows this warning can appear in one of the installshield screens

        Show
        farshid Farshid Ghods (Inactive) added a comment - per bug scrub the warning message can appear during or after setup is completed. on linux this warning will appear in the terminal. on windows this warning can appear in one of the installshield screens
        Hide
        perry Perry Krug added a comment -

        When you say during or after setup...how will that be displayed in the terminal/installshield?

        I know it's a bit more work, but a simple screen at the beginning of the setup wizard that has a list of minimum requirements and whether the system meets them (thinking green check marks and red x'es) giving the user the ability to see what the requirements are and giving them a bit of a flag on whether they are met...but not preventing them from moving forward.

        Or are we thinking of actually preventing the installation?

        Show
        perry Perry Krug added a comment - When you say during or after setup...how will that be displayed in the terminal/installshield? I know it's a bit more work, but a simple screen at the beginning of the setup wizard that has a list of minimum requirements and whether the system meets them (thinking green check marks and red x'es) giving the user the ability to see what the requirements are and giving them a bit of a flag on whether they are met...but not preventing them from moving forward. Or are we thinking of actually preventing the installation?
        Hide
        bcui Bin Cui added a comment -

        For window installshield: Show minimum requirements for RAM: 4GB, CPU cores: 4

        http://review.couchbase.org/#/c/23920/

        Show
        bcui Bin Cui added a comment - For window installshield: Show minimum requirements for RAM: 4GB, CPU cores: 4 http://review.couchbase.org/#/c/23920/
        Hide
        kzeller kzeller added a comment -

        Added to 2.0.1 RN as:

        Install Fix:

        We now provide a warning message on minimal system requirements for
        Couchbase Server. This appears on Linux in the terminal, and on Windows as a
        InstallShield screen.

        Show
        kzeller kzeller added a comment - Added to 2.0.1 RN as: Install Fix: We now provide a warning message on minimal system requirements for Couchbase Server. This appears on Linux in the terminal, and on Windows as a InstallShield screen.

          People

          • Assignee:
            bcui Bin Cui
            Reporter:
            ketaki Ketaki Gangal
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes