Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-7551

Performance Regression after increase in high/low watermarks

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.1
    • Component/s: couchbase-bucket
    • Security Level: Public
    • Labels:
      None

      Description

      We need to investigate this and decide on whether we need to revert the changes.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        dipti Dipti Borkar added a comment -

        Ronnie, please attached your reports from performance runs.

        Assigning this to Jin right now because he's been driving the capacity planning stuff of late, please re-assign as required.

        Show
        dipti Dipti Borkar added a comment - Ronnie, please attached your reports from performance runs. Assigning this to Jin right now because he's been driving the capacity planning stuff of late, please re-assign as required.
        Hide
        jin Jin Lim (Inactive) added a comment -

        Ronnie, when data is available please attach your reports from the performance runs here. Also, for better understanding, let's be specific in what rate of performance degradation we are talking about here. Please assign it back to me after you have attached the requested reports.

        Show
        jin Jin Lim (Inactive) added a comment - Ronnie, when data is available please attach your reports from the performance runs here. Also, for better understanding, let's be specific in what rate of performance degradation we are talking about here. Please assign it back to me after you have attached the requested reports.
        Hide
        ronnie Ronnie Sun (Inactive) added a comment -

        With higher water mark settings:

        • low cache miss (1%) looks good/
        • higher cache miss tests with high mem_quota( ~ 93%) is worse, which might be causing by high swap usage. Attached some graphs. QA team will test (especially with 2.0.1 build) and confirm.
        Show
        ronnie Ronnie Sun (Inactive) added a comment - With higher water mark settings: low cache miss (1%) looks good/ higher cache miss tests with high mem_quota( ~ 93%) is worse, which might be causing by high swap usage. Attached some graphs. QA team will test (especially with 2.0.1 build) and confirm.
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        per bug scrub - assigning back to Jin

        Show
        farshid Farshid Ghods (Inactive) added a comment - per bug scrub - assigning back to Jin
        Hide
        jin Jin Lim (Inactive) added a comment -

        From the latest round of performance test (Ronnie), high/low water mark changes seem to be OK. However, we would like to still wait for high cache miss ratio test and confirmation from QE (Ketaki).

        Show
        jin Jin Lim (Inactive) added a comment - From the latest round of performance test (Ronnie), high/low water mark changes seem to be OK. However, we would like to still wait for high cache miss ratio test and confirmation from QE (Ketaki).
        Hide
        jin Jin Lim (Inactive) added a comment -

        Ketaki, please assign it back to Jin or mark it as resolved once your test (high cache miss) completed with concrete result. Thanks!

        Show
        jin Jin Lim (Inactive) added a comment - Ketaki, please assign it back to Jin or mark it as resolved once your test (high cache miss) completed with concrete result. Thanks!
        Hide
        ketaki Ketaki Gangal added a comment -

        Not seeing any system-regression on build 2.0.1-140 so far.
        No higher swap w/ higher cache-miss ( 5-20 %)

        Show
        ketaki Ketaki Gangal added a comment - Not seeing any system-regression on build 2.0.1-140 so far. No higher swap w/ higher cache-miss ( 5-20 %)
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        Ketaki

        can you please post the graph which shows that there is not much swap usage int he cluster after X days

        also it helps if you print out the tcmalloc fragmentation output here priori to resolving the issue

        Show
        farshid Farshid Ghods (Inactive) added a comment - Ketaki can you please post the graph which shows that there is not much swap usage int he cluster after X days also it helps if you print out the tcmalloc fragmentation output here priori to resolving the issue
        Hide
        ketaki Ketaki Gangal added a comment -

        Refer page-10 for swap stats. Swap on the current cluster did not grow w/ the change in High/Low Watermarks.

        Show
        ketaki Ketaki Gangal added a comment - Refer page-10 for swap stats. Swap on the current cluster did not grow w/ the change in High/Low Watermarks.

          People

          • Assignee:
            ketaki Ketaki Gangal
            Reporter:
            dipti Dipti Borkar
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes