Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-7786

[RN 2.0.2] Frequent replication start error messages "Failed to grab remote bucket info, vbucket.." at start of replication.


    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.1.0
    • Component/s: ns_server
    • Security Level: Public
    • Environment:
    • Flagged:
      Release Note


      Seeing 2 issues when trying to setup replication for the first time between two clusters -

      1.Frequently seeing error messages on creating the 1st time replication from cluster1 to cluster2.
      "Failed to grab remote bucket info, vbucket.."

      Both the buckets on source/destination are available for a long period of time, so it does not look like it is an issue w/ bucket not being ready.

      I dont have logs on this currently, will add soon.

      Seeing this across platforms - linux / windows and on most 2.0.1 runs.

      2.Replication replicates data as expected, and these error messages persist for over an hour on the xdcr-last 10 errors. This gives user a wrong idea about the state of replication.

      The intial Replication-call should either wait long enough to avoid these errors/ figure out if something else can be done here.

      And also, how frequently do we clean up the xdcr-error messages on the console? Can we clear them sooner than current time?


          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.



              • Assignee:
                ketaki Ketaki Gangal
                ketaki Ketaki Gangal
              • Votes:
                0 Vote for this issue
                5 Start watching this issue


                • Created:

                  Gerrit Reviews Side Panel

                  Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerrit-reviews-side-panel'. Please contact your JIRA administrators.