Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-7821

yum install couchbase-server from couchbase repo failed ( no mirrors to try )

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.1
    • Component/s: build
    • Security Level: Public
    • Labels:
      None

      Description

      [root@ip-10-147-132-5 ~]# sudo yum list available couchbase-server
      Loaded plugins: amazon-id, product-id, rhui-lb, security, subscription-manager
      Updating certificate-based repositories.
      Unable to read consumer identity
      couchbase | 951 B 00:00
      couchbase/primary | 33 kB 00:00
      couchbase 2/2
      Available Packages
      couchbase-server.x86_64 2.0.1-155 couchbase
      [root@ip-10-147-132-5 ~]# sudo yum install couchbase-server
      Loaded plugins: amazon-id, product-id, rhui-lb, security, subscription-manager
      Updating certificate-based repositories.
      Unable to read consumer identity
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package couchbase-server.x86_64 0:2.0.1-155 will be installed
      --> Processing Dependency: libssl.so.6()(64bit) for package: couchbase-server-2.0.1-155.x86_64
      --> Processing Dependency: libcrypto.so.6()(64bit) for package: couchbase-server-2.0.1-155.x86_64
      --> Running transaction check
      ---> Package openssl098e.x86_64 0:0.9.8e-17.el6_2.2 will be installed
      --> Finished Dependency Resolution

      Dependencies Resolved

      ================================================================================
      Package Arch Version Repository Size
      ================================================================================
      Installing:
      couchbase-server
      x86_64 2.0.1-155 couchbase 121 M
      Installing for dependencies:
      openssl098e x86_64 0.9.8e-17.el6_2.2 rhui-us-east-1-rhel-server-releases 761 k

      Transaction Summary
      ================================================================================
      Install 2 Package(s)

      Total download size: 122 M
      Installed size: 368 M
      Is this ok [y/N]: y
      Downloading Packages:
      (1/2): couchbase-server-community_2.0.1.x86_64.rpm | 121 MB 01:15
      http://packages.couchbase.com/releases/couchbase-server/linux/rpm/5/x86_64/couchbase-server-community_2.0.1.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=couchbase clean metadata
      Trying other mirror.
      (2/2): openssl098e-0.9.8e-17.el6_2.2.x86_64.rpm | 761 kB 00:00

      Error Downloading Packages:
      couchbase-server-2.0.1-155.x86_64: failure: couchbase-server-community_2.0.1.x86_64.rpm from couchbase: [Errno 256] No more mirrors to try.

        Issue Links

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Hide
          plabee Phil Labee (Inactive) added a comment -

          I am unable to login to this machine and verify myself:

          1. Please copy your /etc/yum.repos.d/couchbase.repo file here.

          2. Did you try to clean the metadata like yum suggested? What were the results?

          Show
          plabee Phil Labee (Inactive) added a comment - I am unable to login to this machine and verify myself: 1. Please copy your /etc/yum.repos.d/couchbase.repo file here. 2. Did you try to clean the metadata like yum suggested? What were the results?
          Hide
          jin Jin Lim added a comment -

          This is 2.0.1 GA blocker, not RC blocker.

          Show
          jin Jin Lim added a comment - This is 2.0.1 GA blocker, not RC blocker.
          Hide
          farshid Farshid Ghods (Inactive) added a comment -

          farshid@ubuntu-1004-x64-307:~$ sudo apt-get install couchbase-server
          Reading package lists... Done
          Building dependency tree
          Reading state information... Done
          The following packages were automatically installed and are no longer required:
          libjson-ruby1.8 libnet-ssh-gateway-ruby1.8 libdigest-sha1-perl
          libmixlib-authentication-ruby1.8 irb1.8 ohai libtreetop-ruby comerr-dev
          libmixlib-log-ruby1.8 ruby-mixlib-shellout openoffice.org-l10n-en-gb
          rubygems libnet-ssh2-ruby1.8 libpolyglot-ruby libwrap0-dev libmoneta-ruby
          java-common libapr1 libmime-types-ruby libkrb5-dev libaprutil1-ldap
          librestclient-ruby1.8 libgssrpc4 libbunny-ruby librestclient-ruby libt1-5
          liberubis-ruby1.8 libreadline5 libaprutil1-dbd-sqlite3 libsystemu-ruby1.8
          libjson-ruby libmixlib-config-ruby tzdata-java libohai-ruby libidn11-dev
          libhighline-ruby1.8 libabstract-ruby1.8 libmixlib-authentication-ruby
          libmixlib-config-ruby1.8 rdoc1.8 libnet-ssh-multi-ruby liberror-perl
          libmixlib-log-ruby libnet-ssh2-ruby libkadm5clnt-mit7 libkadm5srv-mit7
          libnet-ssh-multi-ruby1.8 vim-runtime libhighline-ruby rubygems1.8
          libbunny-ruby1.8 libkdb5-4 libmixlib-cli-ruby krb5-multidev
          libmixlib-cli-ruby1.8 libreadline-ruby1.8 libyajl-ruby libmoneta-ruby1.8
          libaprutil1 php5-common libohai-ruby1.8 liberubis-ruby libldap2-dev
          Use 'apt-get autoremove' to remove them.
          The following extra packages will be installed:
          libssl0.9.8
          The following NEW packages will be installed:
          couchbase-server libssl0.9.8
          0 upgraded, 2 newly installed, 0 to remove and 228 not upgraded.
          Need to get 983kB/122MB of archives.
          After this operation, 366MB of additional disk space will be used.
          Do you want to continue [Y/n]? y
          WARNING: The following packages cannot be authenticated!
          couchbase-server
          Install these packages without verification [y/N]? y
          Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main libssl0.9.8 0.9.8k-7ubuntu8.14 [983kB]
          Fetched 983kB in 20s (48.1kB/s)
          Preconfiguring packages ...
          Selecting previously deselected package libssl0.9.8.
          (Reading database ... 93031 files and directories currently installed.)
          Unpacking libssl0.9.8 (from .../libssl0.9.8_0.9.8k-7ubuntu8.14_amd64.deb) ...
          Selecting previously deselected package couchbase-server.
          Unpacking couchbase-server (from .../couchbase-server_2.0.0_amd64.deb) ...
          Installing cannot proceed since the package 'libssl0.9.8' is missing.
          Please install libssl0.9.8 and try again.

          $sudo apt-get install libssl0.9.8

          You can also restart couchbase as follows:

          $sudo /etc/init.d/couchbase-server start

          dpkg: error processing /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb (--unpack):
          subprocess new pre-installation script returned error exit status 1
          Errors were encountered while processing:
          /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb
          E: Sub-process /usr/bin/dpkg returned an error code (1)
          farshid@ubuntu-1004-x64-307:~$ sudo apt-get install couchbase-server
          Reading package lists... Done
          Building dependency tree
          Reading state information... Done
          The following packages were automatically installed and are no longer required:
          libjson-ruby1.8 libnet-ssh-gateway-ruby1.8 libdigest-sha1-perl
          libmixlib-authentication-ruby1.8 irb1.8 ohai libtreetop-ruby comerr-dev
          libmixlib-log-ruby1.8 ruby-mixlib-shellout openoffice.org-l10n-en-gb
          rubygems libnet-ssh2-ruby1.8 libpolyglot-ruby libwrap0-dev libmoneta-ruby
          java-common libapr1 libmime-types-ruby libkrb5-dev libaprutil1-ldap
          librestclient-ruby1.8 libgssrpc4 libbunny-ruby librestclient-ruby libt1-5
          liberubis-ruby1.8 libreadline5 libaprutil1-dbd-sqlite3 libsystemu-ruby1.8
          libjson-ruby libmixlib-config-ruby tzdata-java libohai-ruby libidn11-dev
          libhighline-ruby1.8 libabstract-ruby1.8 libmixlib-authentication-ruby
          libmixlib-config-ruby1.8 rdoc1.8 libnet-ssh-multi-ruby liberror-perl
          libmixlib-log-ruby libnet-ssh2-ruby libkadm5clnt-mit7 libkadm5srv-mit7
          libnet-ssh-multi-ruby1.8 vim-runtime libhighline-ruby rubygems1.8
          libbunny-ruby1.8 libkdb5-4 libmixlib-cli-ruby krb5-multidev
          libmixlib-cli-ruby1.8 libreadline-ruby1.8 libyajl-ruby libmoneta-ruby1.8
          libaprutil1 php5-common libohai-ruby1.8 liberubis-ruby libldap2-dev
          Use 'apt-get autoremove' to remove them.
          The following NEW packages will be installed:
          couchbase-server
          0 upgraded, 1 newly installed, 0 to remove and 228 not upgraded.
          1 not fully installed or removed.
          Need to get 0B/121MB of archives.
          After this operation, 363MB of additional disk space will be used.
          WARNING: The following packages cannot be authenticated!
          couchbase-server
          Install these packages without verification [y/N]? Y
          (Reading database ... 93051 files and directories currently installed.)
          Unpacking couchbase-server (from .../couchbase-server_2.0.0_amd64.deb) ...
          Installing cannot proceed since the package 'libssl0.9.8' is missing.
          Please install libssl0.9.8 and try again.

          $sudo apt-get install libssl0.9.8

          You can also restart couchbase as follows:

          $sudo /etc/init.d/couchbase-server start

          dpkg: error processing /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb (--unpack):
          subprocess new pre-installation script returned error exit status 1
          Errors were encountered while processing:
          /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb
          E: Sub-process /usr/bin/dpkg returned an error code (1)

          Show
          farshid Farshid Ghods (Inactive) added a comment - farshid@ubuntu-1004-x64-307:~$ sudo apt-get install couchbase-server Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: libjson-ruby1.8 libnet-ssh-gateway-ruby1.8 libdigest-sha1-perl libmixlib-authentication-ruby1.8 irb1.8 ohai libtreetop-ruby comerr-dev libmixlib-log-ruby1.8 ruby-mixlib-shellout openoffice.org-l10n-en-gb rubygems libnet-ssh2-ruby1.8 libpolyglot-ruby libwrap0-dev libmoneta-ruby java-common libapr1 libmime-types-ruby libkrb5-dev libaprutil1-ldap librestclient-ruby1.8 libgssrpc4 libbunny-ruby librestclient-ruby libt1-5 liberubis-ruby1.8 libreadline5 libaprutil1-dbd-sqlite3 libsystemu-ruby1.8 libjson-ruby libmixlib-config-ruby tzdata-java libohai-ruby libidn11-dev libhighline-ruby1.8 libabstract-ruby1.8 libmixlib-authentication-ruby libmixlib-config-ruby1.8 rdoc1.8 libnet-ssh-multi-ruby liberror-perl libmixlib-log-ruby libnet-ssh2-ruby libkadm5clnt-mit7 libkadm5srv-mit7 libnet-ssh-multi-ruby1.8 vim-runtime libhighline-ruby rubygems1.8 libbunny-ruby1.8 libkdb5-4 libmixlib-cli-ruby krb5-multidev libmixlib-cli-ruby1.8 libreadline-ruby1.8 libyajl-ruby libmoneta-ruby1.8 libaprutil1 php5-common libohai-ruby1.8 liberubis-ruby libldap2-dev Use 'apt-get autoremove' to remove them. The following extra packages will be installed: libssl0.9.8 The following NEW packages will be installed: couchbase-server libssl0.9.8 0 upgraded, 2 newly installed, 0 to remove and 228 not upgraded. Need to get 983kB/122MB of archives. After this operation, 366MB of additional disk space will be used. Do you want to continue [Y/n] ? y WARNING: The following packages cannot be authenticated! couchbase-server Install these packages without verification [y/N] ? y Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main libssl0.9.8 0.9.8k-7ubuntu8.14 [983kB] Fetched 983kB in 20s (48.1kB/s) Preconfiguring packages ... Selecting previously deselected package libssl0.9.8. (Reading database ... 93031 files and directories currently installed.) Unpacking libssl0.9.8 (from .../libssl0.9.8_0.9.8k-7ubuntu8.14_amd64.deb) ... Selecting previously deselected package couchbase-server. Unpacking couchbase-server (from .../couchbase-server_2.0.0_amd64.deb) ... Installing cannot proceed since the package 'libssl0.9.8' is missing. Please install libssl0.9.8 and try again. $sudo apt-get install libssl0.9.8 You can also restart couchbase as follows: $sudo /etc/init.d/couchbase-server start dpkg: error processing /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb (--unpack): subprocess new pre-installation script returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) farshid@ubuntu-1004-x64-307:~$ sudo apt-get install couchbase-server Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: libjson-ruby1.8 libnet-ssh-gateway-ruby1.8 libdigest-sha1-perl libmixlib-authentication-ruby1.8 irb1.8 ohai libtreetop-ruby comerr-dev libmixlib-log-ruby1.8 ruby-mixlib-shellout openoffice.org-l10n-en-gb rubygems libnet-ssh2-ruby1.8 libpolyglot-ruby libwrap0-dev libmoneta-ruby java-common libapr1 libmime-types-ruby libkrb5-dev libaprutil1-ldap librestclient-ruby1.8 libgssrpc4 libbunny-ruby librestclient-ruby libt1-5 liberubis-ruby1.8 libreadline5 libaprutil1-dbd-sqlite3 libsystemu-ruby1.8 libjson-ruby libmixlib-config-ruby tzdata-java libohai-ruby libidn11-dev libhighline-ruby1.8 libabstract-ruby1.8 libmixlib-authentication-ruby libmixlib-config-ruby1.8 rdoc1.8 libnet-ssh-multi-ruby liberror-perl libmixlib-log-ruby libnet-ssh2-ruby libkadm5clnt-mit7 libkadm5srv-mit7 libnet-ssh-multi-ruby1.8 vim-runtime libhighline-ruby rubygems1.8 libbunny-ruby1.8 libkdb5-4 libmixlib-cli-ruby krb5-multidev libmixlib-cli-ruby1.8 libreadline-ruby1.8 libyajl-ruby libmoneta-ruby1.8 libaprutil1 php5-common libohai-ruby1.8 liberubis-ruby libldap2-dev Use 'apt-get autoremove' to remove them. The following NEW packages will be installed: couchbase-server 0 upgraded, 1 newly installed, 0 to remove and 228 not upgraded. 1 not fully installed or removed. Need to get 0B/121MB of archives. After this operation, 363MB of additional disk space will be used. WARNING: The following packages cannot be authenticated! couchbase-server Install these packages without verification [y/N] ? Y (Reading database ... 93051 files and directories currently installed.) Unpacking couchbase-server (from .../couchbase-server_2.0.0_amd64.deb) ... Installing cannot proceed since the package 'libssl0.9.8' is missing. Please install libssl0.9.8 and try again. $sudo apt-get install libssl0.9.8 You can also restart couchbase as follows: $sudo /etc/init.d/couchbase-server start dpkg: error processing /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb (--unpack): subprocess new pre-installation script returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/couchbase-server_2.0.0_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
          Hide
          plabee Phil Labee (Inactive) added a comment -

          Debian repo now repaired. The key is that after modifying the /etc/apt/sources.list file, must run "sudo apt-get update".

          This has been made explicit in the instructions on the wiki page:

          http://hub.internal.couchbase.com/confluence/display/CR/How+to+Use+a+Linux+Repo+--+ubuntu+debian#HowtoUseaLinuxRepo--ubuntudebian-ConfigureaClienttoUsetheRepository

          Will encapsultate these instructions in a bash script that the user can download and run.

          Show
          plabee Phil Labee (Inactive) added a comment - Debian repo now repaired. The key is that after modifying the /etc/apt/sources.list file, must run "sudo apt-get update". This has been made explicit in the instructions on the wiki page: http://hub.internal.couchbase.com/confluence/display/CR/How+to+Use+a+Linux+Repo+--+ubuntu+debian#HowtoUseaLinuxRepo--ubuntudebian-ConfigureaClienttoUsetheRepository Will encapsultate these instructions in a bash script that the user can download and run.
          Hide
          plabee Phil Labee (Inactive) added a comment -

          see CBQE-1071 for verification

          Show
          plabee Phil Labee (Inactive) added a comment - see CBQE-1071 for verification

            People

            • Assignee:
              plabee Phil Labee (Inactive)
              Reporter:
              farshid Farshid Ghods (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes