Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-8142

couchbase-cli cluster-init requires username (-u) and password (-p) to init clean cluster

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: None
    • Component/s: tools
    • Security Level: Public
    • Labels:
      None
    • Environment:
      build 2.0.2-769, centos64

      Description

      1. have clean( non-init) cluster
      2013-04-22 15:50:17 | INFO | MainProcess | MainThread | [rest_client.diag_eval] /diag/eval status on 10.3.121.115:8091: True content: ok command: gen_server:cast(ns_cluster, leave).

      2. /opt/couchbase/bin/couchbase-cli cluster-init --cluster=localhost --cluster-init-username=Administrator --cluster-init-password=password --cluster-init-port=8091 --cluster-init-ramsize=300
      ERROR: unable to access the REST API - please check your username (-u) and password (-p)

      I guess for clean cluster -u & -p parameters should be not mandatory

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        andreibaranouski Andrei Baranouski added a comment -

        seems like node was initialized when I have run cluster-init

        Show
        andreibaranouski Andrei Baranouski added a comment - seems like node was initialized when I have run cluster-init

          People

          • Assignee:
            bcui Bin Cui (Inactive)
            Reporter:
            andreibaranouski Andrei Baranouski
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes