Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1110

GetFromReplica times out if key does not exist

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Fixed
    • 2.2.7
    • 2.3.0
    • library
    • None

    Description

      The retry loop is missing the condition where the key does not exist and thus keeps looping until the timeout is raised. The method should fail immediately if the key doesn't exist.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jmorris Jeff Morris created issue -
          jmorris Jeff Morris added a comment -

          I cannot replicate - pushing passing integration and unit tests to gerrit for review - perhaps i am missing something or this is tied to a specific CB version.

          jmorris Jeff Morris added a comment - I cannot replicate - pushing passing integration and unit tests to gerrit for review - perhaps i am missing something or this is tied to a specific CB version.
          jmorris Jeff Morris made changes -
          Field Original Value New Value
          Status New [ 10003 ] Open [ 1 ]
          jmorris Jeff Morris made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          jmorris Jeff Morris added a comment -

          Looking deeper...

          jmorris Jeff Morris added a comment - Looking deeper...
          jmorris Jeff Morris made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          jmorris Jeff Morris made changes -
          Fix Version/s 2.3.0 [ 12831 ]
          Fix Version/s 2.2.8 [ 13348 ]
          jmorris Jeff Morris made changes -
          Priority Major [ 3 ] Critical [ 2 ]
          jmorris Jeff Morris made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          ingenthr Matt Ingenthron made changes -
          Workflow Couchbase SDK Workflow [ 59956 ] Couchbase SDK Workflow with Review [ 246270 ]

          People

            jmorris Jeff Morris
            jmorris Jeff Morris
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty