Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1315

.NET client does not set the HELO correctly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.11
    • Fix Version/s: 2.4.1
    • Component/s: library
    • Labels:
      None

      Description

      .Net is not provide any information in the HELO not sure how this is related to NCBC-1171

      Steps to reproduce

      1. Run the following .Net program

        using System;
        using System.Collections.Generic;
        using System.Threading;
        using Couchbase;
        using Couchbase.Configuration.Client;
         
        namespace CouchbaseLock
        {
        	class MainClass
        	{
        		public static void Main(string[] args)
        		{
        			ClusterHelper.Initialize();
        			var bucket = ClusterHelper.GetBucket("default");
         
        			var doc = new Document<dynamic>
        			{
        				Id = "NET",
        				Content = new
        				{
        					name = "Couchbase"
        				}
        			};
        			bucket.Upsert(doc.Id, doc);
        		}
        	}
        }
        

      2. Tail the memcached.log (please note that memcached writes to the log every 30 seconds)

        tail -f  /opt/couchbase/var/lib/couchbase/logs/memcached.log.000000.txt
        

      Problem
      The HELO from .Net contains no information:

      2017-02-14T10:39:28.694876Z NOTICE 43: HELO [ 10.112.171.1:49307 - 10.112.171.101:11210 ]
      

      Here is libcouchbase HELO for comparison

      2017-02-13T14:21:44.236528Z NOTICE 43: HELO [libcouchbase/2.7.1] TCP NODELAY [ 10.112.171.1:58688 - 10.112.171.101:11210 ]
      

      Expectation
      The HELO from .Net to contain at least the SDK version like the other SDK do. Some SDK like Java go further and provided the JVM details which might also be useful in the .Net case too:

      2017-02-13T01:12:41.383199Z NOTICE 50: HELO [couchbase-java-client/${project.version} (git: ${git.commit.id.describe}, core: ${git.commit.id.describe}) (Linux/3.10.0-123.20.1.el7.x86_64 amd64; Java HotSpot(TM) 64-Bit Server VM 1.8.0_45-b14)] TCP NODELAY [ 10.112.151.102:53180 - 10.112.151.102:11210 ]
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

            jmorris Jeff Morris added a comment -

            The SDK and version were removed with this commit: https://github.com/couchbase/couchbase-net-client/commit/347e660d9d18bf4b98d922f275b29e73ceb00f22

            I am not sure why, maybe Michael Goldsmith can comment? I would say, we just add it back in.

            -Jeff

            jmorris Jeff Morris added a comment -

            Actually, it looks like it was moved internally into Hello.cs...perhaps just never sent to server? So a bug?

            mike.goldsmith Michael Goldsmith added a comment -

            Yeah, the Hello.cs has a new constructor overload which should set the SDK version when no explicit key is passed in. I'll take a look but feels a like a bug.


              People

              • Assignee:
                mike.goldsmith Michael Goldsmith
                Reporter:
                pvarley Patrick Varley
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes

                    PagerDuty

                    Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.