Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1443

Support Getting Cluster Version via SDK, handling authentication for 5.0 RBAC

    XMLWordPrintable

Details

    • New Feature
    • Status: Resolved
    • Major
    • Resolution: Done
    • None
    • 2.5.0
    • library
    • None

    Description

      It would be helpful to have a standard method for getting the cluster version in the SDK.  To date this has been done independently by the Linq2Couchbase client.  However, this has resulted in some code duplication between them.

      Additionally, RBAC in 5.0 now requires authentication to access the /pools endpoint to get the version.  Since none of the authentication information from the SDK is publicly accessible, Linq2Couchbase currently has no way to get the cluster version (unless an out of band method for providing authentication to the LINQ client was provided, which would be cumbersome).

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            jmorris Jeff Morris added a comment -

            Perhaps this is something that can be added to ClusterManager.ClusterInfo()?

            jmorris Jeff Morris added a comment - Perhaps this is something that can be added to ClusterManager.ClusterInfo()?

            Jeff Morris

            Perhaps, but the problem is compatibility.  For Linq2Couchbase, this needs to work for clients configured the old way with bucket auth only, running against pre-5.0 and post-5.0 servers.  CreateManager currently requires that you supply a username/password or have called Authenticate on the cluster.

            Brant

            btburnett3 Brant Burnett added a comment - Jeff Morris Perhaps, but the problem is compatibility.  For Linq2Couchbase, this needs to work for clients configured the old way with bucket auth only, running against pre-5.0 and post-5.0 servers.  CreateManager currently requires that you supply a username/password or have called Authenticate on the cluster. Brant

            We have identified a possible RFC to standardise the way SDKs get cluster server information - the draft for this RFC below:

            https://docs.google.com/document/d/1d6j0R0BFloQgoQ981PjAzv2AWfAIRPlkBLvlCMG7ipY/edit?ts=595224e4#

            mike.goldsmith Michael Goldsmith added a comment - We have identified a possible RFC to standardise the way SDKs get cluster server information - the draft for this RFC below: https://docs.google.com/document/d/1d6j0R0BFloQgoQ981PjAzv2AWfAIRPlkBLvlCMG7ipY/edit?ts=595224e4#
            jmorris Jeff Morris added a comment -

            Moving this into 2.5.0, since it looks like the implementation is still in flux. Michael Goldsmith feel free to move it back to 2.4.8 if you think it will be resolved in time.

            jmorris Jeff Morris added a comment - Moving this into 2.5.0, since it looks like the implementation is still in flux. Michael Goldsmith feel free to move it back to 2.4.8 if you think it will be resolved in time.

            People

              btburnett3 Brant Burnett
              btburnett3 Brant Burnett
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty