Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1485

GetAndLock no longer returns TemporaryLockFailureException when the key is locked on CB 5.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.4.8
    • Fix Version/s: 2.5.0
    • Component/s: library
    • Labels:
      None

      Description

      The server (as of 5.0) no long returns "LOCK_ERROR" as part of the response when a lock error is encountered. The SDK previously used this and the TEMP_FAILURE status to determine the cause of the error and the assign the correct exception type. Instead k/v error map should be used to determine the reason for the exception.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          jmorris Jeff Morris added a comment -

          This appears to be covered in this patch: http://review.couchbase.org/#/c/79816/18 for NCBC-1405


            People

            • Assignee:
              jmorris Jeff Morris
              Reporter:
              jmorris Jeff Morris
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.