Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1518

When an operation fails because of auth failure it is re-tried

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5.0
    • Fix Version/s: 2.5.5
    • Component/s: library
    • Labels:
      None

      Description

      Example output:

      2017-09-11 16:38:07,215 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 1 retries using vb669 from rev2101 and opaque19. Reason: KV Error:

      {Name="EACCESS", Description="Not authorized for command", Attributes="support"} (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: 76becd56-8504-41ab-f69b-73bce80dd59f)
      2017-09-11 16:38:07,318 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,319 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 2 retries using vb669 from rev2101 and opaque19. Reason: KV Error: {Name="EACCESS", Description="Not authorized for command", Attributes="support"}

      (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: 920e6301-f877-4cf0-aa6d-92570c2ab9ca)
      2017-09-11 16:38:07,419 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,419 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 3 retries using vb669 from rev2101 and opaque19. Reason: KV Error:

      {Name="EACCESS", Description="Not authorized for command", Attributes="support"} (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: 10104228-aa8e-4478-c223-8013cabf16d3)
      2017-09-11 16:38:07,521 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,521 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 4 retries using vb669 from rev2101 and opaque19. Reason: KV Error: {Name="EACCESS", Description="Not authorized for command", Attributes="support"}

      (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: f407d272-9005-4774-3baa-5d9f6633735f)
      2017-09-11 16:38:07,623 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,623 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 5 retries using vb669 from rev2101 and opaque19. Reason: KV Error:

      {Name="EACCESS", Description="Not authorized for command", Attributes="support"} (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: bb5dcaab-fa26-4321-cdd5-5aef3fbd3cdf)
      2017-09-11 16:38:07,724 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,725 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 6 retries using vb669 from rev2101 and opaque19. Reason: KV Error: {Name="EACCESS", Description="Not authorized for command", Attributes="support"}

      (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: ae76bd2a-19bd-4feb-6480-f93a2bf568eb)
      2017-09-11 16:38:07,826 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,826 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 7 retries using vb669 from rev2101 and opaque19. Reason: KV Error:

      {Name="EACCESS", Description="Not authorized for command", Attributes="support"} (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: 829fb4a2-4324-4d2d-2d47-3fe031be33be)
      2017-09-11 16:38:07,928 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:07,928 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 8 retries using vb669 from rev2101 and opaque19. Reason: KV Error: {Name="EACCESS", Description="Not authorized for command", Attributes="support"}

      (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: b4677f2a-7197-4260-61a1-362367910a09)
      2017-09-11 16:38:08,029 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:08,029 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 9 retries using vb669 from rev2101 and opaque19. Reason: KV Error:

      {Name="EACCESS", Description="Not authorized for command", Attributes="support"}

      (Context: Authorization failure: can't execute GET operation without the Read privilege, Ref #: 4a3c93b1-fa5a-4c71-a181-e5f3be3d3bea)
      2017-09-11 16:38:08,131 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Get`1 with key Can_Create_And_Count_Subdoc_Property using server 10.111.170.101:11210
      2017-09-11 16:38:08,131 [

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          mike.goldsmith Michael Goldsmith added a comment -

          Unable to reproduce using current HEAD with the following configuration:

          • Enterprise Edition 5.0.0 build 3516
          • add bucket default
          • create custom user with 'data_writer' permission (note: test requires both read and write)
          • update config.json with user credentials and host IP

          My local log has the same message, but does not retry.

          2017-09-27 15:14:57,062 [Worker#STA_NP] DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key Can_Create_And_Count_Subdoc_Property failed after 1 retries using vb669 from rev25 and opaque12. Reason: KV Error: {Name="EACCESS", Description="Not authorized for command", Attributes="support"} (Context: Authorization failure: can't execute SUBDOC_GET_COUNT operation without the Read privilege, Ref #: 025fd49f-a370-4c34-ab2e-36684db3b151)

          jmorris Jeff Morris added a comment -

          It appears to be related error map, here is another example where a locked key is retried until it times out:

          2018-01-22 15:21:10,523 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending Set`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:10,528 Worker#STA_NP DEBUG Couchbase.Core.Buckets.CouchbaseRequestExecuter - Operation Set`1 succeeded 1 for key roikatz :
          2018-01-22 15:21:10,530 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:10,532 Worker#STA_NP DEBUG Couchbase.Core.Buckets.CouchbaseRequestExecuter - Operation GetL`1 succeeded 1 for key roikatz : bbbb
          2018-01-22 15:21:10,535 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:10,539 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 1 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}
          2018-01-22 15:21:10,741 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:10,743 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 2 retries using vb426 from rev28 and opaque10. Reason: KV Error: {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:10,944 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:10,944 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 3 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}
          2018-01-22 15:21:11,145 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:11,146 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 4 retries using vb426 from rev28 and opaque10. Reason: KV Error: {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:11,347 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:11,348 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 5 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}
          2018-01-22 15:21:11,549 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:11,550 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 6 retries using vb426 from rev28 and opaque10. Reason: KV Error: {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:11,750 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:11,751 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 7 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}
          2018-01-22 15:21:11,953 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:11,954 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 8 retries using vb426 from rev28 and opaque10. Reason: KV Error: {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:12,155 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:12,155 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 9 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}
          2018-01-22 15:21:12,356 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:12,357 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 10 retries using vb426 from rev28 and opaque10. Reason: KV Error: {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:12,559 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:12,561 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 11 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}
          2018-01-22 15:21:12,762 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:12,762 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 12 retries using vb426 from rev28 and opaque10. Reason: KV Error: {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:12,964 Worker#STA_NP DEBUG Couchbase.Core.Server - Sending GetL`1 with key roikatz using server 10.142.171.101:11210
          2018-01-22 15:21:12,964 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 13 retries using vb426 from rev28 and opaque10. Reason: KV Error:

          {Name="LOCKED", Description="Requested resource is locked", Attributes="item-locked,item-only,retry-now"}

          2018-01-22 15:21:13,165 Worker#STA_NP DEBUG Couchbase.Core.Buckets.RequestExecuterBase - Operation for key roikatz failed after 13 retries using vb426 from rev28 and opaque10. Reason: The operation has timed out.

          jmorris Jeff Morris added a comment - - edited

          When error map is used, the Status for a locked key will be false, which means it will go into the retry loop until it times out. Is this the correct behavior, or should a status of locked immediately be returned?

          I suspect this happens for any failure when error map is used. This appears to happen for any operation which allows retries - insert for example correctly fails immediately.


            People

            • Assignee:
              jmorris Jeff Morris
              Reporter:
              jmorris Jeff Morris
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.