Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1711

N1Ql requests can be routed to wrong cluster

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.5.10
    • 2.6.0
    • library
    • None
    • 1

    Description

      It has been reported that when a Cluster object is created with buckets configurations defined for for buckets that exist on different clusters, query requests may get routed to the wrong cluster - this needs to be investigated further. 

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jmorris Jeff Morris added a comment - - edited

          The issue is related to Uri caching - specifically the Uri cache is overwritten by the most recent config change that has occurred. A possible fix is either to use hash-table to store the uri's where the key is bucketConfig or something uniquely identifying the configuration or by making the Uri cache instance an variable and passing the CouchbaseConfigContext down to each layer that needs to use it.

          https://github.com/couchbase/couchbase-net-client/blob/master/Src/Couchbase/Configuration/CouchbaseConfigContext.cs#L258-L260

          jmorris Jeff Morris added a comment - - edited The issue is related to Uri caching - specifically the Uri cache is overwritten by the most recent config change that has occurred. A possible fix is either to use hash-table to store the uri's where the key is bucketConfig or something uniquely identifying the configuration or by making the Uri cache instance an variable and passing the CouchbaseConfigContext down to each layer that needs to use it. https://github.com/couchbase/couchbase-net-client/blob/master/Src/Couchbase/Configuration/CouchbaseConfigContext.cs#L258-L260
          jmorris Jeff Morris added a comment -

          final stages of review...

          jmorris Jeff Morris added a comment - final stages of review...

          People

            jmorris Jeff Morris
            jmorris Jeff Morris
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty